Results 1 to 4 of 4
  1. #1
    Live to RIDE. brendus's Avatar
    Join Date
    Jan 2008
    Location
    Melbourne, Australia
    Posts
    326

    NO MORE CAVITATION with r&d X

    i cut the back bit of the r&d grate like the stock X grate has but left the scoop alone. no more cavitation. i still need to try it in the chop if it keeps the ski hooked up without the tunnel closed. top speed on the rxpx 71.8
    Is it possible that the closing of the tunnel increased speed by reducing amount of water going into the pump. i also might add that i left the back centre piece in.


  2. #2
    Live to RIDE. brendus's Avatar
    Join Date
    Jan 2008
    Location
    Melbourne, Australia
    Posts
    326
    heres a picture. it work really well but the back ends that are cut need to be cut on an angle like original so water doesnt hit a stop
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	14072008(001).jpg 
Views:	127 
Size:	300.9 KB 
ID:	82863  

  3. #3
    12timeworldchamps's Avatar
    Join Date
    Feb 2006
    Location
    Maryland
    Posts
    445
    +1
    9
    Quote Originally Posted by brendus View Post
    heres a picture. it work really well but the back ends that are cut need to be cut on an angle like original so water doesnt hit a stop
    Did you try and keep the angle roughly the same as the front scoop? Did you just use a hacksaw?

    Ed

  4. #4
    Live to RIDE. brendus's Avatar
    Join Date
    Jan 2008
    Location
    Melbourne, Australia
    Posts
    326
    one i did with just a hacksaw, the other one without the wings on the scoop i have tried to give an angle. i think the angle will be better cause the other one felt a bit like it was dragging. now just wait for the worx grate

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. no more Power with RotaxRacing 137 SC Impeller !!!!!
    By RXP-X 2011 in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-11-2013, 05:15 AM
  2. Should I run a little more octane with 160psi?
    By javiert99 in forum 4-Tec Performance
    Replies: 9
    Last Post: 10-01-2006, 10:32 PM
  3. no 2 beeps with RR ecu normal?
    By excess in forum 4-Tec Performance
    Replies: 5
    Last Post: 09-06-2006, 05:39 PM
  4. NO more up sh!t creek without a paddle
    By elebouef in forum Yamaha Open Discussion
    Replies: 3
    Last Post: 04-14-2006, 07:35 AM
  5. No more mods for a while.
    By RXPinMD in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 01-14-2006, 08:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •