Results 1 to 5 of 5

Thread: 97 GTX bogging

  1. #1

    97 GTX bogging

    I need mystical powers! Please get out your crystal balls out! 97 GTX boggs on trailer @ around 4500 rpms. Sometimes if I hold it at 5000 rpms for a while it will take off but only for a second. I have:

    -Replaced gas lines
    -Rebuilt carbs (tested pop-off @30psi and pressure tested)
    -Replaced fuel valve
    -Replaced fuel filter assy
    -Cleaned filter on fuel baffle in tank
    -Put in clean gas
    -Replaced spark plugs
    -Trimmed ends of spark plug wires
    -Tested voltage (12.34v not running & 13.86v @ 5500rpms)
    -Compression test - 130 both cylinders
    -Pulled rave valves inspected and cleaned

    -Did 180 check

    Had similar experience last summer was a broken rave valve spring. Could the springs in there now be wrong? Is there a way to check this?

    Any other leads would be greatly appreciated!!

    Thanks a bunch,
    Marty


  2. #2
    JayZ's Avatar
    Join Date
    Feb 2006
    Location
    mississauga, ontario
    Posts
    407
    +1
    1
    my bet is your rectifier has gone bad. it is located in the front electrical box. it is square with 3 yellow wires and one red wire coming out of it. disconnect the red wire and see if your problem goes away. don't run it too long out on the water as you will no longer be charging your battery.

  3. #3
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Fix him up Jay...

  4. #4
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    1,925
    +1
    66
    Check all exhaust hoses for a soft spot which will expand while running & cause the problem you described. Its kinna like the old potato in the exhaust pipe trick.

    My 2nd guess would be bad crank bearings that are dragging & causing a excessive load.

  5. #5
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    When you rebuilt the carbs did you clean the internal filter screens?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 97 GTX still bogging
    By 05RXP in forum 2-Stroke Performance
    Replies: 5
    Last Post: 08-10-2007, 06:03 PM
  2. 97 GTX giving me fits - any advice?
    By ucrewx5 in forum 2-Stroke Performance
    Replies: 6
    Last Post: 08-01-2007, 06:45 AM
  3. 97 GTX Problem
    By Paul Willoughby in forum 2-Stroke Performance
    Replies: 6
    Last Post: 07-29-2007, 12:05 PM
  4. 97 GTX problem. Help!!!!!
    By mongo in forum 2-Stroke Performance
    Replies: 2
    Last Post: 07-14-2007, 07:27 PM
  5. Dead hour meter on '97 GTX
    By KevinS in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 05-14-2007, 08:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •