Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 25
  1. #1
    MyGreenGumby's Avatar
    Join Date
    May 2007
    Location
    West islip, NY / Portsmouth, RI
    Posts
    230

    Ughh riding this weekend - Carnage pics

    Went to my friends lake house- unloaded the skis at 630 rode for a lil and then rxp start smoking NG - So I stopped riding that and rode the standup and x2. Here are some pics of what happen












    So at the end of this im gonna need:

    Water Box
    3 inch couple from jpipe to wb
    one of those sensors that got burnt
    1 clamp for the exhaust gasket.

    it seems that something clogged I blew out the line to the graco strainer and nothing came out.

    Any suggestions??


  2. #2
    AKA: Larry lafjax's Avatar
    Join Date
    Jul 2006
    Location
    Jacksonville, Fl
    Posts
    3,032
    Didn't the temp alarm go off???
    Smells?

  3. #3

    Join Date
    Jul 2005
    Location
    euxton nr chorley lancashire, england
    Posts
    1,500
    +1
    1
    Quote Originally Posted by MyGreenGumby View Post
    Went to my friends lake house- unloaded the skis at 630 rode for a lil and then rxp start smoking NG - So I stopped riding that and rode the standup and x2. Here are some pics of what happen












    So at the end of this im gonna need:

    Water Box
    3 inch couple from jpipe to wb
    one of those sensors that got burnt
    1 clamp for the exhaust gasket.

    it seems that something clogged I blew out the line to the graco strainer and nothing came out.

    Any suggestions??
    the exhaust hi temp light and bleeper should have given you some warning, was it working?

  4. #4
    Treemn's Avatar
    Join Date
    Jun 2007
    Location
    Coral Springs FL
    Posts
    3,316
    +1
    634
    Wow I wish I had the answer But DARN THAT IS SOME BAD STUFF

  5. #5

    Join Date
    Jul 2005
    Location
    euxton nr chorley lancashire, england
    Posts
    1,500
    +1
    1
    intercooler is partially blocked, you'll also want some bailer tubes

  6. #6
    shhr's Avatar
    Join Date
    May 2005
    Location
    Springfield,TN
    Posts
    2,546
    +1
    311
    the hose that goes from the back of the hull the one with the reducer when you remove the pump must be stopped up or the 3 holes in the "J" pipe before it goes into the water box are blocked if water was flowing thru the hose then out the 3 holse this would not have happened

  7. #7
    MyGreenGumby's Avatar
    Join Date
    May 2007
    Location
    West islip, NY / Portsmouth, RI
    Posts
    230
    Quote Originally Posted by lafjax View Post
    Didn't the temp alarm go off???
    Smells?
    SMELLLS awful - I have a inline graco strainer so anything that may have clogged up. I wasnt riding it at the time we unloaded it from the trailer rode it from the ramp to the house and it started smoking so we idling it back I figured something had to be clogged up in there. From the pump to the water line I blew out and flushed out.

    Where else should I check you think?

  8. #8
    outboard john's Avatar
    Join Date
    Jun 2006
    Location
    Escondido, Ca.
    Posts
    474
    +1
    2
    Umm, barbeque on pontoon boat, good, on RXP, not good Bummer. Good luck.
    OBJ

  9. #9
    MyGreenGumby's Avatar
    Join Date
    May 2007
    Location
    West islip, NY / Portsmouth, RI
    Posts
    230
    Quote Originally Posted by outboard john View Post
    Umm, barbeque on pontoon boat, good, on RXP, not good Bummer. Good luck.
    OBJ
    HAHA - yeah there was enough smoke to be bbq tons of burgers ribs and what not.


    Anyone have any good deals on Water box- waterbox coupling, sensor, and strap?

  10. #10
    Kaybat's Avatar
    Join Date
    Aug 2005
    Location
    Fl
    Posts
    1,735
    +1
    28
    Quote Originally Posted by lafjax View Post
    Didn't the temp alarm go off???
    Smells?

    +1

    i have heard of some people burning holes in waterboxes before....

    when i overheated my 03(exhaust hose blew during a lightening/t storm...long story) the temp sensor melted and that was all she wrote....

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. So did you ride this weekend or what ? 10/14/07
    By MIARider in forum Southeast
    Replies: 4
    Last Post: 10-15-2007, 02:50 PM
  2. Guess I can't ride this weekend - too much water!
    By mjammer in forum Open Discussion
    Replies: 2
    Last Post: 08-25-2007, 09:32 AM
  3. Where are the Texas guys riding this weekend?
    By 97GPSLEEPER in forum Yamaha Open Discussion
    Replies: 13
    Last Post: 08-31-2006, 10:38 AM
  4. Who is riding this weekend in SW Florida?
    By Smitty in forum Yamaha Open Discussion
    Replies: 2
    Last Post: 08-12-2006, 09:46 AM
  5. finally got a chance to go for a ride this weekend
    By mxl16 in forum 4-Tec Performance
    Replies: 1
    Last Post: 04-01-2006, 07:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •