Results 1 to 9 of 9
  1. #1

    ultra 150 wont rev past 4000 rpm

    my ultra 150 wont rev past 400 rpm in the water put will rev good out of the water any suggestion to this problem i am running a set of novi 44 carbs with r&d intake


  2. #2
    Change the plugs and see if it goes away.

  3. #3
    btldigger's Avatar
    Join Date
    Feb 2007
    Location
    lebanon tn.
    Posts
    1,641
    Sounds like you are only running on 2 cylinders. Change plugs and check for fire. You could also run it on the hose and feel the plug bases to find the dead one. That would be a start.

  4. #4
    thesepaperwings's Avatar
    Join Date
    May 2007
    Location
    South East Kansas
    Posts
    1,283
    +1
    1
    Check your comp while you're at it.

  5. #5
    Check compresion. Could be a reed or a piston issue. Also look for any plugs that are not pluged in, could be a sensor.

  6. #6
    hey thanks it is the first piston gone bad

  7. #7
    hey thanks it is the first piston gone bad

  8. #8
    Do work son ultra150nc's Avatar
    Join Date
    Apr 2008
    Location
    Charlotte
    Posts
    235
    i got one laying around I THINK* if i can find it ill send to you if you want it. PM if so

  9. #9
    Do work son ultra150nc's Avatar
    Join Date
    Apr 2008
    Location
    Charlotte
    Posts
    235
    I think i got one laying around i can send you PM me if you want it

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 99 Ultra 150 wont rev past 5500 rpms
    By ktyamaha36 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 9
    Last Post: 03-06-2017, 12:03 PM
  2. 96 SLT 780 help. Motor wont rev past 4000
    By nz253 in forum Polaris Open Discussion
    Replies: 32
    Last Post: 10-11-2015, 05:45 PM
  3. 09 Ultra 260 wont rev past 7000 rpm
    By CayRider in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 06-22-2015, 12:37 PM
  4. 1996 sl780 wont rev past 4000
    By snoopy'sbitch in forum Polaris Open Discussion
    Replies: 31
    Last Post: 06-30-2010, 05:36 PM
  5. 96 sl900 wont get past 4000 rpm
    By gianni57 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 10-17-2007, 12:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •