Results 1 to 7 of 7
  1. #1
    Reservoir Dawg BobOnThis's Avatar
    Join Date
    Oct 2007
    Location
    O-H-I-O
    Posts
    331
    +1
    3

    O6 RXP Problems (oil leak)

    I had my 06 rxp out last week and first off let me say its bone stock with 100hrs on it. My brother ended up putting about 5 gallons of 89 octane in it when I was not at the lake house and riding for a while. Well when I went to put it on the trailer I got on it and it was kicking down to like 3500rpms and bogging real bad but not dying all the way. I thought it was because of the low octane so I put some high test back in it to boost it back up. I took it out again last weekend and the same thing happened. It would get some fast spurts but then go back down the the sputtering real bad. I took the seat off and I see oil coming out of the screw that holds the oil filter in and think this may be the prob?? So I bring the ski back in check the screw..its tight..replace the rubber washer and re add oil..the oil leak is gone the octane is up, but I am still having sputtering issues with the ski occationally? Any ideas?


  2. #2
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    The first thing I would do is change the plugs. Are you getting any codes?... Ron

  3. #3
    Reservoir Dawg BobOnThis's Avatar
    Join Date
    Oct 2007
    Location
    O-H-I-O
    Posts
    331
    +1
    3
    Quote Originally Posted by King_Of_Fun View Post
    The first thing I would do is change the plugs. Are you getting any codes?... Ron
    I am going to change the plugs tonight. Any recommendations for just NGK's? No I had no sirens or buzzers and I don't know how to check for codes on a 06rxp?

  4. #4

    Join Date
    Jul 2005
    Location
    euxton nr chorley lancashire, england
    Posts
    1,500
    +1
    1
    Quote Originally Posted by BobOnThis View Post
    I am going to change the plugs tonight. Any recommendations for just NGK's? No I had no sirens or buzzers and I don't know how to check for codes on a 06rxp?
    is it not still press the set button 5 times ?, i don't know cos mines an 05

  5. #5
    JSR Brad Clarke's Avatar
    Join Date
    Nov 2007
    Location
    Christchurch, New Zealand
    Posts
    119
    06 has no set button, you need buds for code reading.
    I would say faulty plug or ignition coil, all the 4techs use the same coils so if it plays up again try to borrow a coil and swap it one by one till the fault goes away and replace that coil.

  6. #6

    Join Date
    Jul 2005
    Location
    euxton nr chorley lancashire, england
    Posts
    1,500
    +1
    1
    Quote Originally Posted by BobOnThis View Post
    I am going to change the plugs tonight. Any recommendations for just NGK's? No I had no sirens or buzzers and I don't know how to check for codes on a 06rxp?
    just clean those plugs and let them sit in the oven for 1 hour gas 6 or electric 200 they'll be good for another 40 hours, just close the gap a shade, they'll be fine till you get another set
    Last edited by jetskibill9999; 07-15-2008 at 07:47 PM.

  7. #7
    Reservoir Dawg BobOnThis's Avatar
    Join Date
    Oct 2007
    Location
    O-H-I-O
    Posts
    331
    +1
    3
    Good deal, I will try all this. Well except I would like to get just some new plugs. Is this a bad idea or something? If I did what is the gap on them?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 05 rxp massive oil leak to bilge.
    By sucks2bu in forum 4-Tec Performance
    Replies: 24
    Last Post: 04-21-2016, 09:31 PM
  2. 2012 RXPX Problems - oil leaking, water in cylinders - Please Help!!
    By NBD Watersports Inc in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-30-2013, 06:31 AM
  3. 2007 rxp 215 oil leak?
    By rearviewneons in forum 4-Tec Performance
    Replies: 18
    Last Post: 03-09-2013, 04:25 PM
  4. Next problem: Oil leak and misfirering.
    By sigga in forum Kawasaki PWC Performance (4-stroke)
    Replies: 11
    Last Post: 05-06-2008, 08:56 AM
  5. I might have a oil leak in the RXP
    By Jrsrxp in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-02-2005, 12:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •