Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    Join Date
    Aug 2007
    Location
    Worthington, MN
    Posts
    100

    Low RPM'S on RXP-X

    From the get go I had low rpm's on rxp-x after my 10 hr service about 7700. Last weekend did a lot playing with a passanger on (spins, tailstands ect. ) We managed to flip it over 3 times but got it back up in seconds. I now have rpm's at a max 7620 mostly 7550 but it was a little warmer (92 vs 80 @7700) I have checked all connections and seem ok. I want to repitch but any thoughts about maybe having other problems besides needing to repitch. Thanks


  2. #2
    REID2168's Avatar
    Join Date
    Jun 2007
    Location
    My House
    Posts
    8,156
    +1
    241
    the dealer may have toppped your oil off to the top bend if they changed it for u and its a bit FULL .........that could be part of the low rpm's if its overfull with oil! good luck!

  3. #3

    Join Date
    May 2008
    Location
    South Eastern Michigan
    Posts
    198
    Quote Originally Posted by REID2168 View Post
    the dealer may have toppped your oil off to the top bend if they changed it for u and its a bit FULL .........that could be part of the low rpm's if its overfull with oil! good luck!
    +1

    I wouldn't re-pitch anything. You're 100% stock. Find the issue (or make sure there isn't one) and then go from there.

    If you were at say 6000RPMs or lower top end, I'd say there's a larger issue (loose IC hose, bad supercharger washers, hamsters hungry, etc.), but this seems to be a smaller issue since your less than 500RPM off. Do you know what your GPS speeds were? (just curious).

    -=Mike G

  4. #4

    Join Date
    Aug 2007
    Location
    Worthington, MN
    Posts
    100
    Oil is fine. Speeds at 7700 were 68.7 in about 75 air temp. Have not gps'd at 7550. Before playing hard with a passanger it seemed like a re-pitch solution but now with it being lower is seems more than than. It still pulls like a champ but top end is not there. Could it be related to playing hard?

  5. #5
    Prohibido usuario
    Join Date
    Aug 2005
    Location
    Jerry's guest bedroom
    Posts
    3,469
    +1
    2
    Did you by chance use the learning key for your breakin period? Probably need to get a compression and leak down test done to see if it falls within norm.

  6. #6

    Join Date
    Jun 2005
    Location
    Hamilton, Ontario, Canada
    Posts
    556
    when you say the oil level is fine, do you mean it is inbetween the bends on the dip stick? If it is higher it will definitely drop your RPM's.

  7. #7

    Join Date
    Aug 2007
    Location
    Worthington, MN
    Posts
    100
    No learner key, and oil is between the two bends. Thanks so far guys but any other thoughts?

  8. #8
    REID2168's Avatar
    Join Date
    Jun 2007
    Location
    My House
    Posts
    8,156
    +1
    241
    Quote Originally Posted by North49 View Post
    when you say the oil level is fine, do you mean it is inbetween the bends on the dip stick? If it is higher it will definitely drop your RPM's.
    EXACTLY!!!!!!!!!!!! i should have been more clear myself!

  9. #9
    REID2168's Avatar
    Join Date
    Jun 2007
    Location
    My House
    Posts
    8,156
    +1
    241
    Quote Originally Posted by Pfeifere View Post
    No learner key, and oil is between the two bends. Thanks so far guys but any other thoughts?


  10. #10
    Prohibido usuario
    Join Date
    Aug 2005
    Location
    Jerry's guest bedroom
    Posts
    3,469
    +1
    2
    Still need to do a compression and leak down test. Check the slip on the SC.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Low RPM's on my Cane'
    By bigpak in forum Polaris PWC Performance
    Replies: 0
    Last Post: 08-14-2014, 05:51 AM
  2. A few Problems Low RPMS & Starting on it's own
    By Kaotic in forum 4-Tec Performance
    Replies: 7
    Last Post: 06-01-2009, 11:30 PM
  3. Low RPM's on 07 RXP
    By Captain C in forum 4-Tec Performance
    Replies: 14
    Last Post: 08-23-2007, 02:07 AM
  4. Question about holeshot RPM's on RXP...
    By Suthrn in forum 4-Tec Performance
    Replies: 4
    Last Post: 06-24-2007, 10:20 PM
  5. Low RPM's on one motor
    By somefun in forum Sea Doo Sport Boats
    Replies: 9
    Last Post: 03-03-2007, 12:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •