Page 1 of 11 1 2 3 ... LastLast
Results 1 to 10 of 105
  1. #1
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4

    Had a scary incident with ski just now, need help guys

    First and foremost... someone better convince me ASAP not to tell this thing and just get 1. a Kawi 15F or 2. a motorcycle and a jetboat.... i'm gettin pretty aggravated and turned off and losing interest.

    ski was running friggen awesome for the past couple weeks. i was achieving speeds i never did before with less mods.

    i pulled the motor, did lotsa hull work, rideplate work, truing, etc.

    ski was re-assembled with the trued hull, modded rideplate, riva sponsons in MIDDLE position, Riva intake grate... i was pulling damn near 71 at only 7800-7900 rpms. i was stoked about it. end of my ride on saturday night, i lost speed.. pull ski out and my riva intake grate was dangling and yanked the inserts out of the pump shoe and broke the back hole of the grate

    last night i repaired the pump shoe inserts with marine expoxy. then today i re-installed the STOCK intake grate since my riva grate broke. while i was at it, i put the riva sponsons in the down position rather than middle. NOTHING else was changed.

    i go ride 2nite... i'm down several mph... and when i let off the throttle the ski acted like it had brakes. i figured ok, my repair job sucked, my intake grate is dangling again.... i continue riding and beating on it WOT no problem. then i'm on the way back and im cruising along at 5000 rpms or so and WHACK it bc the ski has been pullin like an f'n freight train from this particular RPM point and it's fun... then what... i hear a thud and the ski starts to take a slight turn all on it's own and i let off the gas immediately... i figured OK... my intake grate is gone, fabulous, now i gotta take it easy all the way home.

    so i'm going along, come across calm water, i nail it and all seems well and i get to 7700 rpms and mid-60 mph and OUCH. i ALMOST went for a nasty tumble, but instead I held on for dear life while my ski veered off REAL SHARP to the left while my bars were straight. my wrists hurt like no other, my ankles rolled, my shin into the footwell, and i think the handlebars might be bent now.

    OK, so the ski doesn't like not having an intake grate and going fast... i take it easy and can comfortably do 30 mph and feel like i have control. get to the ramp, take it out.... SON OF A BITCH!!! the intake grate is still there, tight, and perfect. both sponsons are there, tight, same height, nothing wrong. reverse bucket is ok, steering cable and rod are ok, steering nozzle is ok, rideplate is good.

    WTF? now what do i do bc i'm a little (embarrassed to say) scared to go back out and nail the ski WOT to test it bc falling off the RXT at 70 is not something i want to do voluntarily. i feel like i'm not gonna wanna open the ski up again full bore until i find something wrong, and i just don't see anything right now.

    i'm upset, pissed, wanting to be done with it and sell it, definitely lost a ton of interest right now and feel like putting it for sale on ebay right now and getting a GPR for 3 grand and saving my money or getting out of it for now and waiting and praying for something better in 07. OR.... ah hell, so much running thru my mind right now.




    STEVE
    Last edited by Shibby1485; 07-18-2006 at 08:11 PM.


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    WTF? Steve you can't find any reason why the ski bucked like that?

  3. #3
    so uh how good did you true the hull and ride plate?

  4. #4
    captain obvious Lurker's Avatar
    Join Date
    Jul 2005
    Location
    Visalia, Ca
    Posts
    2,316
    Have you yanked on the intake grate? I have heard of the grate only droping down at speed and doing exactly what you described.

  5. #5
    ccassone's Avatar
    Join Date
    Nov 2005
    Location
    Branford, Connecticut
    Posts
    357
    Shibbs is your shoe coming loose and dragging on one side? At a higher speed it could start to drop a little and grab and pull to the left. Check the left side of the shoe. Think about it, that is the only explaination. Your ski has no opas, you have no loose sponsons and your steering is good. It has to a loose or poorly alligned shoe/rideplate. Glad you're not hurt, and good luck.Charlie

  6. #6
    Jarrett's Avatar
    Join Date
    Apr 2005
    Location
    Waxahachie, TX
    Posts
    3,011
    +1
    77
    Damn Shibby, I'm sorry to hear that. I've never heard of a ski behaving like that. Maybe something in the pump is F'ed from the broken intake grate? Is this the first broken RXP/T Riva intake grate?

  7. #7
    GTXX's Avatar
    Join Date
    Jan 2006
    Location
    NW, GA
    Posts
    1,776
    check your motor mounts

  8. #8
    someone had a story about the intake dropping down and they launched off the front at about 70. Your story could have been alot worse.
    I'd do like Lurker said and yank on it. Maybe have someone else yank on it for you. Just don't yank it too hard it or it might bend. Then it will hand to one side. Try not to yank on it too much either you might go blind.

    Now get it fixed and get back to breaking speed records!! Can't wait till you get it all bolted back. If you sell it I got dibs on the rideplate

  9. #9
    Moderator boataddict's Avatar
    Join Date
    Apr 2005
    Location
    Ottawa, Ontario, Canada
    Posts
    3,822
    +1
    39
    Steve,
    Make sure that the grate is really ok. Get under it and give it a good tug to make sure is wasn't dropping at speed.
    I am glad you are ok.

  10. #10
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    i can't find or see anything wrong so far... it's driving me nuts... gonna eat my dinner real quick right now (i'm sitting on front of computer with dinner, lol) ... then i'm gonna get under the ski and have a closer look at things and yank on the grate and see if the entire pump shoe is loose or anything...

    grate is sitting in there even and not cocked to one side or anything.

    how good did i true the hull and rideplate? they were professionally done by sonmeone real good, well the hull was, and i did the rideplate.i been runing it for 2-3 weeks with flawless results... the only things changed were riva to stock grate and lowered the sponsons just one notch.

    ski ran perfect for about an hour (aside from slight speed loss) and there was no bucking at all at WOT for an hour of riding... then all the sudden a thump which i thought was either hitting something in the water or the grate ripping off. i was convinced it was the grate ripping off... but the hull is in perfect shape, no damage, and every component is tight and intact.

Page 1 of 11 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Lets spend money now need help upgrading my skis
    By rockonup in forum 4-Tec Performance
    Replies: 10
    Last Post: 07-13-2013, 08:36 PM
  2. Took the ski out today Need help
    By cmher18 in forum 4-Tec Performance
    Replies: 22
    Last Post: 04-05-2010, 08:36 AM
  3. Took the ski out today Need help
    By cmher18 in forum 4-Tec Performance
    Replies: 0
    Last Post: 04-03-2010, 11:14 PM
  4. Newbie with a 05 rxp needing help!
    By PWC Newbie in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-13-2009, 12:22 AM
  5. just bought a 947 engine with custom work done need help
    By fit4lyph in forum 2-Stroke Performance
    Replies: 25
    Last Post: 07-31-2009, 07:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •