Results 1 to 9 of 9
  1. #1

    rxpx problem at 3 hours

    hi there my digi rpm says always 5000 or 0 and the fuel gauge doesnt show anything ,also jumped it today and the engine bogged a bit .how to change fom f to c on temp dial thanks guys for any tips


    bye the way wot a awesome ski,but my gpr handles chop better


  2. #2
    Prohibido usuario
    Join Date
    Aug 2005
    Location
    Jerry's guest bedroom
    Posts
    3,469
    +1
    2
    That's why you have a warranty, Take it to the dealer.

  3. #3
    Moderator Franko's Avatar
    Join Date
    Apr 2005
    Location
    Dallas, Texas
    Posts
    3,829
    +1
    2
    Quote Originally Posted by nobbyq View Post
    hi there my digi rpm says always 5000 or 0 and the fuel gauge doesnt show anything ,also jumped it today and the engine bogged a bit .how to change fom f to c on temp dial thanks guys for any tips


    bye the way wot a awesome ski,but my gpr handles chop better
    Take it to the dealer and have them reprogram your ECU.

    You must have some serious handling mods on your GPR.

  4. #4
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Quote Originally Posted by nobbyq View Post
    hi there my digi rpm says always 5000 or 0 and the fuel gauge doesnt show anything ,also jumped it today and the engine bogged a bit .how to change fom f to c on temp dial thanks guys for any tips


    bye the way wot a awesome ski,but my gpr handles chop better
    Where are you located? I've read that some dealers outside the US don't have the software yet to do the update... Ron

  5. #5
    Prohibido usuario
    Join Date
    Aug 2005
    Location
    Jerry's guest bedroom
    Posts
    3,469
    +1
    2
    I think it's a faulty gauge. Maybe the ECU.

  6. #6
    based in the uk,hope this is not sign of things to come ,3 hours already problems ! one other thing it reads on middle bit in between dials " t 501 " whereby the numbers changes ...was does this mean

  7. #7

    Join Date
    Jul 2005
    Location
    euxton nr chorley lancashire, england
    Posts
    1,500
    +1
    1
    Quote Originally Posted by nobbyq View Post
    based in the uk,hope this is not sign of things to come ,3 hours already problems ! one other thing it reads on middle bit in between dials " t 501 " whereby the numbers changes ...was does this mean
    i'm in the uk wats it all about

  8. #8
    Moderator Franko's Avatar
    Join Date
    Apr 2005
    Location
    Dallas, Texas
    Posts
    3,829
    +1
    2
    Did your gauges ever read accurately? If not, then it is probably just an improperly programed ECU. That is an easy fix for the dealer. If it used to read accurately, it's probably a gauge problem. That is also an easy warranty repair.

  9. #9
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Shibby posted a Service Bulletin on this a few months ago, but I don't see it now... Ron

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Supercharger Maintenance message at 63 hours??? 2008 RXPX
    By tchies in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-02-2011, 09:17 PM
  2. STX 12f problems at high hours discussion
    By matrixman16 in forum Kawasaki Open Discussion
    Replies: 7
    Last Post: 05-26-2010, 03:30 PM
  3. 2009 Seadoo RXPX Supercharger at 100 hours
    By sseilacher in forum 4-Tec Performance
    Replies: 10
    Last Post: 05-20-2010, 04:16 AM
  4. Big problem at 110 hours
    By gotpurp305 in forum 4-Tec Performance
    Replies: 4
    Last Post: 09-14-2008, 10:57 PM
  5. any problems at 100 hours?
    By bazemore in forum 4-Tec Performance
    Replies: 10
    Last Post: 08-30-2008, 03:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •