Results 1 to 7 of 7

Thread: t tsat testing

  1. #1

    t tsat testing

    i have a tstat which i think is from a sl 750. (see pic) and i am going to put in on my sl 650 but my question is how do i tets this for function can i put the whole thing in boiling water? and at what temd should it open at? thnaks please respond fast as i am going tomorrow and i need to have this done. thanks
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Picture 085.jpg 
Views:	23 
Size:	1.74 MB 
ID:	83331   Click image for larger version. 

Name:	Picture 086.jpg 
Views:	20 
Size:	1.98 MB 
ID:	83332   Click image for larger version. 

Name:	Picture 087.jpg 
Views:	21 
Size:	2.04 MB 
ID:	83333  

  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Dont install the thermostat and you will be fine with just the pop-off valve.

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    near Toronto, Canada
    Quote Originally Posted by smartalec_87 View Post
    I have a thermostat which I think is from a SL750. do i test this for function...? what temp should it open at?
    You can check the Service Manual, but I think it opens at around 143F. You can test it in a pot of water. Heat the water gently (not boiling), and watch when it opens.

    Unless you ride in very cold water, you can get away with removing the thermostat.

  4. #4
    i ride mostly in nor cal so would u all recomend removing it? or keeping it in? thanks

  5. #5
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Campbell, Ca.
    I'm in Northern Cali and I don't have a thermostat in anything PWC I own,ust be sure to give it some warm up time. We idle ours out a few minutes before rocking.

  6. #6
    so take out the gasket around the t stat too? (not the main o-ring) thanks

  7. #7
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Campbell, Ca.
    Correct get rid of the ring on the thermostat as well. The almost 8 on the cover will do the sealing and assure no leak. Be sure to clean the surfaces well and use a sealant if you didn't replace the 8 ring.
    Your pop off valve looks like it's in good shape, don't forget it's seal.

    21 here.
    Last edited by ph2ocraft; 07-17-2008 at 12:42 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Franks Stage-3 testing today
    By peteshauling in forum 4-Tec Performance
    Replies: 17
    Last Post: 09-11-2008, 01:54 PM
  2. Today's test results 5/9/05
    By Jrsrxp in forum 4-Tec Performance
    Replies: 12
    Last Post: 05-10-2005, 01:32 PM
  3. My Mods and test results
    By CRAZEDRXP in forum 4-Tec Performance
    Replies: 14
    Last Post: 05-05-2005, 07:38 AM
  4. test
    By CRAZEDRXP in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 05-04-2005, 03:33 PM
  5. Replies: 1
    Last Post: 04-30-2005, 10:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts