Results 1 to 8 of 8
  1. #1

    95 XP with no spark

    I have a stock 95 seadoo xp 720cc that stopped running. The motor turns over and the plugs have fuel on them but there is no spark. The ski was running fine and then all the sudden shut off while riding it. I checked all the fuses and connections and everything looks good. Does anyone know what could be wrong? Stator? Ignition regulator? I really appreciate the help...

    Thanks,

    Dave


  2. #2
    Treemn's Avatar
    Join Date
    Jun 2007
    Location
    Coral Springs FL
    Posts
    3,325
    +1
    641
    Check and make sure the small black ground that goes on the neg side of the battery is not corroded or loose or just connected

  3. #3
    I checked ensuring all the connections were clean and tight on both ends. This thing cut our while ridding it.

  4. #4
    Treemn's Avatar
    Join Date
    Jun 2007
    Location
    Coral Springs FL
    Posts
    3,325
    +1
    641
    it is just not the black battry cable there is a 12 gauge wire that comes loose or gets corroded

  5. #5
    Treemn's Avatar
    Join Date
    Jun 2007
    Location
    Coral Springs FL
    Posts
    3,325
    +1
    641
    it comes out ofthe black box where the coils are and plug wires you could also try to unscrew the plug caps and trim the ends just 1/8 inch or so.

  6. #6
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    check your fuses and you may have to trim back the spark plug wires and re-connect the boot. check your ground that goes to the block, it may be corroded or bad/ rusty ground.

  7. #7
    Alright, I will check those things. Do stators just go bad?

  8. #8
    1996XP's Avatar
    Join Date
    May 2008
    Location
    Virginia Beach, VA
    Posts
    168
    Read this, mine did the exact same thing last week!!!!! And it was a relatively easy fix!!


    http://www.greenhulk.net/forums/showthread.php?t=64014
    Last edited by 1996XP; 07-17-2008 at 07:07 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS: '96 Sea Doo XP 800 No spark $900
    By pisgah in forum Sea Doo Classifieds
    Replies: 7
    Last Post: 12-13-2008, 01:44 PM
  2. Need Help 1994 Seadoo gtx with no spark
    By Polaris rider 1 in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 09-21-2008, 01:55 PM
  3. Newbie w/2 95 sl750s and no spark in 1
    By dhuber1 in forum Polaris Projects
    Replies: 30
    Last Post: 05-18-2008, 10:38 PM
  4. '96 XP 800, no spark
    By waterbug in forum 2-Stroke Performance
    Replies: 25
    Last Post: 03-06-2008, 09:43 PM
  5. 95 ZXI 900 No Spark
    By Speedy4 in forum Kawasaki Open Discussion
    Replies: 3
    Last Post: 11-27-2007, 06:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •