Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 24
  1. #1

    Join Date
    Jun 2005
    Location
    Hamilton, Ontario, Canada
    Posts
    556

    Odd noise after replacing wear ring

    Recently I replaced my wear ring as the old one need replacing. At the same time I added a Riva grate. My RPM's and top end were back to where they were before, so I have to assume everything was put back together correctly. However whenever I turn sharp at any significant speed I hear this wierd noise coming from the area of the impeller/wear ring. It's a winey noise almost as if the impeller is hitting the wear ring. Actually when looking at the new wear ring I can tell the prop has made contact, but figured some is normal due the movement of the drive shaft. I do not recall this when the ski was new, so did I do something wrong when installing the wear ring? Or with the addition of the riva grate is it forcing more water into the impeller causing it to hit the wear ring?
    I thought about putting the stock grate on to see if it did this put I just filled the ride plate and grate holes, so I was hoping to avoid this. Anyone else experienced this?


  2. #2
    Resident Jicky Jack Jeff C's Avatar
    Join Date
    May 2005
    Location
    Twin Cities, MN
    Posts
    1,153
    Describe the noise better. I have noticed a weird noise as well after changing to the Riva grate, but I was hesitant to post because I could not describe the noise. On hard turns it sounds like "beeeeeeeuuuup" sort of a long noise lasting through the turn. It started doing this after my skat bearing mod / Riva grate mod, so I can't tell which one is doing this.

  3. #3

    Join Date
    Jun 2005
    Location
    Hamilton, Ontario, Canada
    Posts
    556
    JeffC.......What you describe is similar to what I am hearing. It lasts the duration of the turn, or at least during the point at which the drag or pull would be the hardest...if that makes sense.

  4. #4
    SpeedStang95's Avatar
    Join Date
    Jul 2005
    Location
    Columbia S.C.
    Posts
    138
    Good job on describing that noise Because I have the same one .......I dunno It came around after I put on my RIVA Grate.......

  5. #5
    Moderator boataddict's Avatar
    Join Date
    Apr 2005
    Location
    Ottawa, Ontario, Canada
    Posts
    3,822
    +1
    39
    I have it as well. It was causing some concern for me.
    I have a Riva Grate and a Solas as well as a new ring.

  6. #6

    Join Date
    Jun 2005
    Location
    Hamilton, Ontario, Canada
    Posts
    556
    Well I am glad I am not the only one.......Anyone one have any ideas? I am just concerned I was going to eventually damage something.

  7. #7
    Moderator boataddict's Avatar
    Join Date
    Apr 2005
    Location
    Ottawa, Ontario, Canada
    Posts
    3,822
    +1
    39
    I am going to have a mechanic at work look at mine this weekend.
    I will let you know if I find anything.

  8. #8

    Join Date
    Jun 2005
    Location
    Hamilton, Ontario, Canada
    Posts
    556
    I am going to have a further look this weekend. Not sure I'll find anything, but if I do I'll let you know as well.

  9. #9
    Kaybat's Avatar
    Join Date
    Aug 2005
    Location
    Fl
    Posts
    1,735
    +1
    28
    It's a whistling noise,correct??My ski makes the same noise w/Riva grate.....someone told me it's actually a little air entering the pump,not sure though

  10. #10
    Resident Jicky Jack Jeff C's Avatar
    Join Date
    May 2005
    Location
    Twin Cities, MN
    Posts
    1,153
    Quote Originally Posted by Kaybat
    It's a whistling noise,correct??My ski makes the same noise w/Riva grate.....someone told me it's actually a little air entering the pump,not sure though

    No, not really a whistling noise. It sounds like "beeeeeeeeeuuuuuuuuuuuup"

    It makes the noise turning both left and right when driving hard(er)

    I really don't mind the noise if it is not hurting anything. I just cannot understand any possible "theory" scenarios as to what physically is happening to make this noise...........

    It seems related to the Riva grate. Anyone else with a Riva grate NOT hearing this weird noise?

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. anyone used prop housing with plastic replaceable wear rings?
    By Autosport in forum Yamaha PWC Performance (2-stroke)
    Replies: 20
    Last Post: 12-26-2007, 09:42 AM
  2. Need Help: Replacing Wear Ring on 97 GTX
    By MPower in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 07-31-2007, 09:27 PM
  3. When to replace wear ring ?
    By txgp1300r in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 10-29-2006, 10:18 PM
  4. When to replace wear ring?
    By HoopsRXT in forum 4-Tec Performance
    Replies: 9
    Last Post: 09-28-2006, 05:54 PM
  5. Finished with replacing wear rings every few hours!
    By RXPDAVID in forum 4-Tec Performance
    Replies: 11
    Last Post: 08-15-2005, 06:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •