Results 1 to 5 of 5
  1. #1

    95 750 Hose Question...

    Since nobody checks on my build thread, heres another question...

    (http://greenhulk.net/forums/showthread.php?t=64156)

    My stock 93 650 jugs had holes in the bottom of them to allow water from the crankcase hose adaptor to run through and cool like it was in the water. I just got the 750 jugs in, and its just a little pocket with no holes where the crankcase water would flow, and of course no water flows using the stock 93 flush kit...

    Is this a problem in any way? Im assuming it will run properly, and the crankcase dosent need water in its channels? I can live without a flush kit, but im just making sure this is ok, or at least normal.


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Yes that is true you can add the flush fitting to the cooling bar opposite the temp sensor.

  3. #3
    Quote Originally Posted by beerdart View Post
    Yes that is true you can add the flush fitting to the cooling bar opposite the temp sensor.
    Ok, that works.

    I suppose I will just leave the connections on my crank case bare and open then.

  4. #4
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    That should work. I like to cap them just in case you have some gasket leakage.

  5. #5
    Hmm, i suppose i can do that.

    Thanks.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 95 SLT 750 Rebuild Question
    By dtescher in forum Polaris Open Discussion
    Replies: 9
    Last Post: 10-14-2013, 09:38 PM
  2. 95 slt 750 coil question
    By weezzell5400 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 05-17-2011, 12:28 PM
  3. '95 750 SL Questions
    By IndyAl in forum Polaris Open Discussion
    Replies: 5
    Last Post: 07-13-2009, 10:52 PM
  4. 95 spx electrical question
    By 95 sl750 in forum 2-Stroke Performance
    Replies: 3
    Last Post: 04-17-2007, 08:51 PM
  5. pump hose question
    By philip_gp1200r in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 04-06-2006, 07:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •