Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 37
  1. #1
    Goliath's Avatar
    Join Date
    Jun 2008
    Location
    Morehead City, NC / Stow, OH
    Posts
    758

    Electrical Box Swapping...

    I just changed the pieces in the electrical box that were rusty, and now I have a new problem. Hoary!!!!!

    So, after I replaced the pieces in the electrical box (terminal and "Strap Assembly") everything appeared to be okay. The display was on an everything, so I decided to try and start it to see how it sounded. I pressed the start/stop button and nothing happened. I looked at the display and it was blank!!! I have no idea what happened?? A fuse maybe??

    Oh and I will post pictures of the old parts in the next post. Pretty rusty on the back of it....
    Last edited by Goliath; 07-17-2008 at 03:09 PM.


  2. #2
    Goliath's Avatar
    Join Date
    Jun 2008
    Location
    Morehead City, NC / Stow, OH
    Posts
    758
    Click image for larger version. 

Name:	100_2253.JPG 
Views:	35 
Size:	509.9 KB 
ID:	83540

    Click image for larger version. 

Name:	100_2254.JPG 
Views:	39 
Size:	579.3 KB 
ID:	83541

  3. #3
    Goliath's Avatar
    Join Date
    Jun 2008
    Location
    Morehead City, NC / Stow, OH
    Posts
    758
    I just took the fuses out. The one being used was black and it had like a black fog on the glass. The spare fuse of the same size was just lack inside? I have never seen black fuses (unless they are blown) so, I have no idea what is going on...

  4. #4
    SPEED KILLS, BUT YOU GET THERE QUICKER Keddano's Avatar
    Join Date
    Jul 2007
    Location
    Cedar Rapids,Iowa
    Posts
    6,381
    +1
    23
    Looks like you blew a fuse,Check it with a ohm meter.Double check your placement of the wires to the spades.Some of the wires look close in color,Sounds like maybe a wire is grounded,or hooked up wrong.

  5. #5
    Goliath's Avatar
    Join Date
    Jun 2008
    Location
    Morehead City, NC / Stow, OH
    Posts
    758
    Also I couldn't get one screw in. The allen screw that is closest to the big and slim black box.... The threading on the piece was delivered messed up and the screw does not go in straight... Not sure if this matters, but I figured I would tell.

  6. #6
    Goliath's Avatar
    Join Date
    Jun 2008
    Location
    Morehead City, NC / Stow, OH
    Posts
    758
    Quote Originally Posted by Keddano View Post
    Looks like you blew a fuse,Check it with a ohm meter.Double check your placement of the wires to the spades.Some of the wires look close in color,Sounds like maybe a wire is grounded,or hooked up wrong.
    What is an ohm meter?

    nvm.... haha

    Does a certain side of the fuse correspond to the ohm meter?
    Last edited by Goliath; 07-17-2008 at 03:38 PM.

  7. #7
    SPEED KILLS, BUT YOU GET THERE QUICKER Keddano's Avatar
    Join Date
    Jul 2007
    Location
    Cedar Rapids,Iowa
    Posts
    6,381
    +1
    23
    There is one of the screws that goes thru the ground strap on the board(The group marked BLK) and grounds everything back to the box and the battery neg cable. Is that the screw your missing?

  8. #8
    Goliath's Avatar
    Join Date
    Jun 2008
    Location
    Morehead City, NC / Stow, OH
    Posts
    758
    Quote Originally Posted by Keddano View Post
    There is one of the screws that goes thru the ground strap on the board(The group marked BLK) and grounds everything back to the box and the battery neg cable. Is that the screw your missing?
    I think that is it. I have the screw, but I think the threading mght be messed up a little? I guess the ski will not start unless this allen screw is in??

  9. #9
    Rocky_Road's Avatar
    Join Date
    Aug 2007
    Location
    Florida Panhandle
    Posts
    826
    Quote Originally Posted by Goliath View Post
    I think that is it. I have the screw, but I think the threading mght be messed up a little? I guess the ski will not start unless this allen screw is in??
    Time to get the metric tap set out of the closet....

  10. #10
    Quote Originally Posted by Goliath View Post
    What is an ohm meter?
    Thats a guy that works at a good repair shop!

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1996 SPX Electrical box question
    By 95 sl750 in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 05-31-2007, 08:18 PM
  2. Pro785 electrical box
    By BigDaddyPT in forum Polaris How To & FAQs
    Replies: 7
    Last Post: 01-08-2007, 05:53 PM
  3. 02 Freedom Electrical Box Picture
    By VegasRatt in forum Polaris PWC Performance
    Replies: 9
    Last Post: 12-25-2006, 10:50 PM
  4. 2002 Freedom Electrical Box
    By VegasRatt in forum Polaris PWC Performance
    Replies: 4
    Last Post: 10-25-2006, 11:29 PM
  5. Want To Re Mount Electrical Box GP1200R
    By Mik72e in forum Yamaha How To & FAQs
    Replies: 4
    Last Post: 09-21-2006, 06:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •