Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23
  1. #1

    Thumbs down Riva Stage One Kit Major Loss of Power

    I jsut installed the Riva stage one kit, I have a Kawi ultra 250 and no my RPM's are 6000 max with top speed 40 mph. I installed a new ride plate, sponsons, free flow exhaust, New water box, new free flow intake. I called Riva they told me the CPU has to reset something the air/fuel mixture. Anyone have this problem and feedback would be appreciated thanks...


  2. #2
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,991
    +1
    455
    Quote Originally Posted by Empirenj250 View Post
    I jsut installed the Riva stage one kit, I have a Kawi ultra 250 and no my RPM's are 6000 max with top speed 40 mph. I installed a new ride plate, sponsons, free flow exhaust, New water box, new free flow intake. I called Riva they told me the CPU has to reset something the air/fuel mixture. Anyone have this problem and feedback would be appreciated thanks...
    What was your speed/rpms before the install?

  3. #3
    I was clocking 62-64 and highest rpm 7800-7850.

  4. #4
    Something is wrong. More then likely your loosing boost from the intercooler you had to remove.

    This is not like the Riva kit at all. You will need to go through your work again to insure it done properly.

    Your location will also help us out, maybe a near by member can help you .

  5. #5
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,991
    +1
    455
    Quote Originally Posted by Skips313 View Post
    Something is wrong. More then likely your loosing boost from the intercooler you had to remove.

    This is not like the Riva kit at all. You will need to go through your work again to insure it done properly.

    Your location will also help us out, maybe a near by member can help you .
    +1

    You did something wrong during your install..

  6. #6
    He's from Concordia NJ, go help a brother out....

  7. #7
    What should I look for? Also I'm only getting 5 lbs of boost... max
    Last edited by Empirenj250; 07-18-2008 at 07:33 PM.

  8. #8
    All I Want......Is All You Got! Fateracing's Avatar
    Join Date
    Jun 2007
    Location
    Cen-Cal
    Posts
    120
    Quote Originally Posted by Skips313 View Post
    Something is wrong. More then likely your loosing boost from the intercooler you had to remove.

    This is not like the Riva kit at all. You will need to go through your work again to insure it done properly.

    Your location will also help us out, maybe a near by member can help you .

    Good call Skip. 5lbs. boost, got a leak.

    Good luck to to everyone going to LB2CAT. See you there.
    Jon #12

  9. #9
    Yep its what I thought. You forgot to tighten a hose clamp on the Intercooler.

    Check all your hose clamps on the intercooler. There are are five and check the BOV valve.

    Big clamp on the SC going to the IC. Big clamp on the IC comming from the SC.
    Throttle boddy hose has two, one on IC and one on throttle body.
    Also check hose clamp on the releif valve comming off the IC.

  10. #10
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    Quote Originally Posted by Empirenj250 View Post
    What should I look for? Also I'm only getting 5 lbs of boost... max
    the answer is right in front of you check all your intake hose clamps from the s/c to the i/c and throttlebody as its leaking boost pressure.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Is riva stage one kit on rxp really worth it ?
    By rxp91 in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-26-2010, 05:18 PM
  2. 09 rxp-x riva stage one kit
    By benjamin rxp x in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 06-10-2010, 08:57 PM
  3. Riva Stage One Kit SHO
    By earwig in forum Yamaha PWC Performance (4-stroke)
    Replies: 1
    Last Post: 04-19-2009, 08:21 AM
  4. Riva stage one kit
    By RxPrider in forum 4-Tec Performance
    Replies: 7
    Last Post: 07-30-2006, 05:41 PM
  5. Where should trim be with riva stage one kit
    By macattack in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-30-2005, 09:46 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •