Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1
    rx4pain's Avatar
    Join Date
    Apr 2005
    Location
    Olympia, WA
    Posts
    1,965
    +1
    2

    X's squeaky steering...

    I only have 22 hours on the ski and when you turn the steering it's got this annoying squeaking. Where to lube?


  2. #2
    Quote Originally Posted by rx4pain View Post
    I only have 22 hours on the ski and when you turn the steering it's got this annoying squeaking. Where to lube?
    I had the same issue when i bought it brand new. I just used wd40

  3. #3
    Alex The Godfather's Avatar
    Join Date
    Jan 2008
    Location
    NC
    Posts
    945
    i have the same issue... im going to use WD-40 and also try to tighten it up some... it seems a lil loose

  4. #4
    MTL Bimmer's Avatar
    Join Date
    May 2010
    Location
    Montreal, QC & State Of Kuwait
    Posts
    52
    Quote Originally Posted by rx4pain View Post
    I only have 22 hours on the ski and when you turn the steering it's got this annoying squeaking. Where to lube?
    Mine has 17 hours and my steering wheels squeaks! Got some wd40, Where do I spray?
    Thanks

  5. #5
    stuckmoto's Avatar
    Join Date
    Jun 2010
    Location
    Newark, De
    Posts
    1,485
    +1
    59
    I sprayed white lithium grease in the steering column when I pulled it out to check on OTAS magnets two summers ago...no squeaks

  6. #6
    mark2m's Avatar
    Join Date
    Mar 2008
    Location
    Greenwood Lake, NY
    Posts
    75
    +1
    2
    Hmm mine has the same squeak when turning the steering also. I'll see if wd40 helps.

  7. #7
    MTL Bimmer's Avatar
    Join Date
    May 2010
    Location
    Montreal, QC & State Of Kuwait
    Posts
    52
    Quote Originally Posted by stuckmoto View Post
    I sprayed white lithium grease in the steering column when I pulled it out to check on OTAS magnets two summers ago...no squeaks
    Aaand how do i do that? Loll

  8. #8
    MTL Bimmer's Avatar
    Join Date
    May 2010
    Location
    Montreal, QC & State Of Kuwait
    Posts
    52
    Quote Originally Posted by mark2m View Post
    Hmm mine has the same squeak when turning the steering also. I'll see if wd40 helps.
    Wd40 didn't work for me

  9. #9
    stuckmoto's Avatar
    Join Date
    Jun 2010
    Location
    Newark, De
    Posts
    1,485
    +1
    59
    Quote Originally Posted by MTL Bimmer View Post
    Aaand how do i do that? Loll
    Simple... remove the front storage bucket,disconnect the front cluster connectors, then loosen the two column bolts and the column will slide out.

    Check the OTAS magnet/sensor while you're there.

  10. #10
    MTL Bimmer's Avatar
    Join Date
    May 2010
    Location
    Montreal, QC & State Of Kuwait
    Posts
    52
    Quote Originally Posted by stuckmoto View Post
    Simple... remove the front storage bucket,disconnect the front cluster connectors, then loosen the two column bolts and the column will slide out.

    Check the OTAS magnet/sensor while you're there.
    Sweet thanks!! I'll try doing that in a bit and will report back asap
    and what is OTAS magnet/sensor? What do I really have to check on it? Lol I'm sorry I'm still a noob with these things haha

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Tilt steering conversion parts list.
    By Green Hulk in forum 4-Tec Performance
    Replies: 20
    Last Post: 09-10-2005, 06:15 PM
  2. Adjusting Steering before my Trip this weekend! quick help
    By Shibby1485 in forum 4-Tec Performance
    Replies: 9
    Last Post: 07-08-2005, 10:14 PM
  3. Anyone tried the R&D Crankcase Breather or Steering Nozz
    By Jarrett in forum 4-Tec Performance
    Replies: 14
    Last Post: 07-06-2005, 09:05 AM
  4. Cobra Jet Steering
    By 1FastTrespiper in forum 4-Tec Performance
    Replies: 7
    Last Post: 06-30-2005, 11:34 AM
  5. U.M.I. steering on a RXP
    By peteshauling in forum 4-Tec Performance
    Replies: 14
    Last Post: 05-09-2005, 03:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •