Results 1 to 4 of 4
  1. #1
    PMart317's Avatar
    Join Date
    Oct 2005
    Location
    Petoskey,Michigan
    Posts
    215

    need some major help!

    hey guys! It's great to be back at the site! I just got in Michigan and unloaded my rxp and knew something was wrong! It's a 06 and only. Has about 27 hours on it. I was riding around and it felt jerky. The rpms kept going back and forth when I had the throttle in one position. back and forth! Started up fine which is awesome but all of our sea doo places are closed and didn't know what to do. We thought it might be spark plugs or bad gas still from the winter...is there something we need to put in gas to clean it out!? Thanks guys!


  2. #2

    Join Date
    Jul 2007
    Location
    Cleveland, Ohio
    Posts
    43
    It would help if you were a little more specific, but check your battery and the terminals to make sure you have a full charge and make sure they are clean. Did you pull the plugs?

  3. #3
    PMart317's Avatar
    Join Date
    Oct 2005
    Location
    Petoskey,Michigan
    Posts
    215
    We have been riding on it and it's getting better! I think it was the fuel injector or something..but it's fine now! When we winterize...since we leave it outside. Do we need to get all the gas out and put sometiing in it?! But thanks it's working good! We needed to warm it up

  4. #4
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28
    Quote Originally Posted by PMart317 View Post
    We have been riding on it and it's getting better! I think it was the fuel injector or something..but it's fine now! When we winterize...since we leave it outside. Do we need to get all the gas out and put sometiing in it?! But thanks it's working good! We needed to warm it up
    By the sounds of it, it may well have just been your injectors with a bit of crap in them. I was going to suggest that maybe the fuel had turned to crap, but if its sorting itself out, tha cant be the case.
    Glad to hear it was nothing major..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need some major help.
    By Jakespiteri in forum Polaris How To & FAQs
    Replies: 22
    Last Post: 07-28-2015, 07:55 AM
  2. Hey Guy's Need Some HP Help
    By somefun in forum 4-Tec Performance
    Replies: 3
    Last Post: 11-20-2006, 05:01 AM
  3. Need some more help i think
    By big83bronco in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 06-19-2006, 09:56 PM
  4. First test with 2 Intercoolers Need Some Impeller Help!
    By somefun in forum 4-Tec Performance
    Replies: 10
    Last Post: 05-14-2006, 07:08 PM
  5. Need some quick help
    By Jrsrxp in forum 4-Tec Performance
    Replies: 3
    Last Post: 04-04-2006, 01:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •