Results 1 to 10 of 10
  1. #1

    SL 750 won't run over 20

    My Polaris SL 750 won't run over 20 mph. It has no low end and top speed is about 20 is all it will do. No take off. Any help will be appreciated.


  2. #2
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    What's compression and MAXRPM's?
    My wild guess is fuel starvation.

  3. #3
    First thing i would do is a compression test. Go to advance/autozone/napa or whatever and buy a compression meter. Stick it in the hole and crank at WOT.

    These guys tell me 60 on the MAG is bad, and forced me into a rebuild.

  4. #4
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,328
    +1
    29
    Many places will rent compression testers for free. Just need a deposit.

    Start there and post back.

  5. #5
    I did a compression test and the end cylinder must have a hole in it. It didn't have any compression. What is entailed in chanaging pistons?

  6. #6
    Wankel till I die!! jonjonwells's Avatar
    Join Date
    Apr 2007
    Location
    SE Kansas
    Posts
    637
    Easy.... Remove cooling rail, then the head, jug, then the piston itself. Reassemble in reverse using new gaskets.

    That is if there is no damage to the cylinder walls and head.

    Unfortunately, that only fixes what is broken, not what caused it to break. When was the last time the fuel system was gone through? Carbs cleaned? Has the fuel pump been upraded to a triple outlet?

  7. #7
    You had... 0 psi compression? You must have SOMETHING if the thing runs. Are you sure you did it correctly?

    Take the heads off and inspect each piston visually, its quite simple. Pull the water rail and take the 6 head bolts off.

  8. #8
    100 MILES OF HEAVEN AND I AM SMACK IN THE MIDDLE KEYZBUM's Avatar
    Join Date
    Apr 2007
    Location
    JUST NORTH OF CUBA-- FL,KEYS
    Posts
    2,556
    +1
    39
    Quote Originally Posted by ZOMGVTEK View Post
    You had... 0 psi compression? You must have SOMETHING if the thing runs. Are you sure you did it correctly?

    Take the heads off and inspect each piston visually, its quite simple. Pull the water rail and take the 6 head bolts off.
    they can run on 2 of the 3 all day long ,,,or atleast 6 miles for me
    you might need to choke it to get it to idle but it WILL run with a hole in a piston not recomended (but hey thats what i am ALL about )
    mattman

  9. #9
    Quote Originally Posted by KEYZBUM View Post
    they can run on 2 of the 3 all day long ,,,or atleast 6 miles for me
    you might need to choke it to get it to idle but it WILL run with a hole in a piston not recomended (but hey thats what i am ALL about )
    mattman
    OHHHHH the end cyl...

    I thought it said all the cyls... LOL

    Yea, it probably does.

  10. #10
    Feral's Avatar
    Join Date
    May 2008
    Location
    Georgetown, Ontario
    Posts
    216
    hehehe I ran mine at WOT with a holed Piston ( actually wasn't holed it detonated the edge )

    P.S. which end Piston the one by the fuel tank or the one next to the driveline
    Mine turned out to be the PTO (Close to the Driveshaft)

    P.S. I ran mine for a few days in that condition unwittingly
    I got a Whopping face blistering ~35mph ROTFL

    http://greenhulk.net/forums/showthread.php?t=63653

    heheh My Ski at WOT for about 20 min (2-3min of video LOL)
    http://www.resellersinc.com/Video_063008_001.mpg

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1994 polaris sl 750 dies after running it all out for a 5-10 minutes
    By abbieg250 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 09-02-2012, 11:11 PM
  2. SL 750 engine not running super/carb settings
    By Morten1988 in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 05-27-2012, 04:42 PM
  3. 750 stx wont go over 20 MPH
    By ppickard in forum Kawasaki PWC Performance (2-stroke)
    Replies: 0
    Last Post: 07-06-2011, 09:01 AM
  4. SL 750 won't plain out
    By polarisrider007 in forum Polaris Open Discussion
    Replies: 8
    Last Post: 06-19-2010, 09:35 AM
  5. Waverunner XLT 1200 won't go over 20 MPH after taking on water
    By mmr11408 in forum Yamaha PWC Performance (2-stroke)
    Replies: 22
    Last Post: 07-07-2008, 06:04 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •