Page 1 of 6 1 2 3 ... LastLast
Results 1 to 10 of 52
  1. #1
    Reservoir Dawg BobOnThis's Avatar
    Join Date
    Oct 2007
    Location
    O-H-I-O
    Posts
    331
    +1
    3

    Does this seem right? A 07 GTX SC beating my RXP?

    Ok, well I am a man so this is hard for me to come to, but I got beat by a 07 gtx supercharged, with a woman driving it twice! I cannot get anything out of my ski! Its an 06 rxp with hardly any mods. It has the OPAS kit, a pop off valve, and ride plates holes filled. I installed a hillbilly airflow kit last week thinking it might help with the temps since I cannot afford a riva kit just yet. So maybe where my filter is, is actually doing that much harm? With the stuff I had its the best I could do and I tried to get it at least near the seat intake. So yes it looks funny and is cobbed all to heck, but like I said I thought it would be better then the stock set up. So here is the deal, this lady wanted to race..I said ok..she took me the first time because I let her whole shot not thinking that ski was that fast..she beat me by 3 lengths...I though well screw that and I tried to whole shot her and her tank still got me at the line and I lost by a length! Now this is on flat water and I did hit a couple waves, that put me out for a second. That ski seems to spend more time out of the water then in and I tried the riva top loader and it seemed to slow me down by about 5mph! So I don't know where to go, but not back to the lake! I was running 110oct, that day on a full tank, no bars even gone and brand new plugs and my oil level is right on with the oil change. Where is my ski bad at? When I could look it was doing I think 7780rpms and my speedo at 67. I don't have my gps so I don't know what exactly my speeds are? Are those skis that fast or is mine that slow? I just don't ever want this to happen again!
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	P1030059.JPG 
Views:	77 
Size:	230.0 KB 
ID:	84136   Click image for larger version. 

Name:	P1030060.JPG 
Views:	52 
Size:	159.5 KB 
ID:	84137   Click image for larger version. 

Name:	cutout.png 
Views:	65 
Size:	1.32 MB 
ID:	84138  


  2. #2
    YoYamma's Avatar
    Join Date
    Aug 2006
    Location
    Central Florida
    Posts
    21,570
    +1
    4,790
    LOL well it does happen, I can tell you we have given some RXP's a hard time especially in the chop, my daughter gave a guy fits the other day, she kicked his azz all the way across the lake and him on a RXP, he came over and told her it's not often you see a girl ride a ski like that, she was on cloud 9, LOL...

    but there are some variables...

    1. get your real speed with a GPS, speedo means little and you need a solid reference point. Fuel level and temp can play a part too, write it all down when you test.

    2. check your wear ring, IMO many Doos are under-performing because of some simple things like this.

    3. don't forget she may have had a modded craft, to quote Forrest Gump---PWC are like a box of chocolates...
    Last edited by YoYamma; 07-20-2008 at 08:14 PM.

  3. #3
    RXTMAN's Avatar
    Join Date
    Jun 2006
    Location
    Lake Dunlap, TX
    Posts
    186
    Why 110 octane gas? With those mods that is NOT needed....

  4. #4
    Doesn't seem to be a good place to put the filter. Right over the exhaust.

  5. #5
    first, the blow off valve may be leaking. second, the intake is probably not helping, reroute it too the front of the ski

    what are your rpms?

  6. #6
    Reservoir Dawg BobOnThis's Avatar
    Join Date
    Oct 2007
    Location
    O-H-I-O
    Posts
    331
    +1
    3
    Well the octane was at 110 and a 50/50 with 93 and some 89 left over. I posted before that my brother put 89 lake gas in it a week a go and I just wanted to boost it back up. It was not pure 110 oct. The rpms said 7780 when I looked down. I kept on trying to check them through the day but the water never laid down flat enough to get an accurate reading but that is the best I came up with. I figured the heat would play a part, but then why wouldn't it on her ski? I will reroute the cold air flow this week and to where the riva goes to and see if that may do anything. I talked to the lady for about a half hour afterwards and she is not the type to fix up the ski. She said it was all stock and her kids hate it because it don't jump and all that jazz, but really said she just bought it because it was a smooth ride and nothing has been done to it. I did notice that the clamp I had on the blow off valve tube seem to have moved like as if I didn't get it tight enough, but it was still on there. I recranked it back down today. Would that cause some signifigant loss? I really didn't notice to much difference in the skis performance. It seem to run like it always has..slow!-lol No, it really does good against the yamis and the hondas, but I even have hard times getting past the rxt's and when I got beat by this tank, I thought..There is something not right here!

  7. #7
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by BobOnThis View Post
    Well the octane was at 110 and a 50/50 with 93 and some 89 left over. I posted before that my brother put 89 lake gas in it a week a go and I just wanted to boost it back up. It was not pure 110 oct. The rpms said 7780 when I looked down. I kept on trying to check them through the day but the water never laid down flat enough to get an accurate reading but that is the best I came up with. I figured the heat would play a part, but then why wouldn't it on her ski? I will reroute the cold air flow this week and to where the riva goes to and see if that may do anything. I talked to the lady for about a half hour afterwards and she is not the type to fix up the ski. She said it was all stock and her kids hate it because it don't jump and all that jazz, but really said she just bought it because it was a smooth ride and nothing has been done to it. I did notice that the clamp I had on the blow off valve tube seem to have moved like as if I didn't get it tight enough, but it was still on there. I recranked it back down today. Would that cause some signifigant loss? I really didn't notice to much difference in the skis performance. It seem to run like it always has..slow!-lol No, it really does good against the yamis and the hondas, but I even have hard times getting past the rxt's and when I got beat by this tank, I thought..There is something not right here!
    If your rpms are 7,780 then you have some power to gain. Depitch the trailering edge of your prop to get to 8,100 rpm.

  8. #8
    That air intake's hurt'n you.

    The bend at the sc...with that material...ain't smooth. Don't know what kind of filter you have on but my bet would be...with that bend and filter your set up is more restrictive than an oem intake.

    and...you found a leak.

  9. #9
    Reservoir Dawg BobOnThis's Avatar
    Join Date
    Oct 2007
    Location
    O-H-I-O
    Posts
    331
    +1
    3
    Quote Originally Posted by YoYamma View Post
    LOL well it does happen, I can tell you we have given some RXP's a hard time especially in the chop, my daughter gave a guy fits the other day, she kicked his azz all the way across the lake and him on a RXP, he came over and told her it's not often you see a girl ride a ski like that, she was on cloud 9, LOL...

    but there are some variables...

    1. get your real speed with a GPS, speedo means little and you need a solid reference point. Fuel level and temp can play a part too, write it all down when you test.

    2. check your wear ring, IMO many Doos are under-performing because of some simple things like this.

    3. don't forget she may have had a modded craft, to quote Forrest Gump---PWC are like a box of chocolates...
    I would of excepted this loss a lot better if the water was choppy or the girl was really good looking.-lol I just replaced the wear ring with a used but good looking one about 2 weeks ago. I did suck up a piece of plastic on Thursday, but I need to get under the ski again to see if this is did something to my wear ring. It really does not have the take off power it seem like it use to. ALSO this ski does have 105hrs on it, I don't know if that makes a difference or not, but its not anywhere near new.

  10. #10
    Reservoir Dawg BobOnThis's Avatar
    Join Date
    Oct 2007
    Location
    O-H-I-O
    Posts
    331
    +1
    3
    Quote Originally Posted by VaRedneck View Post
    That air intake's hurt'n you.

    The bend at the sc...with that material...ain't smooth. Don't know what kind of filter you have on but my bet would be...with that bend and filter your set up is more restrictive than an oem intake.

    and...you found a leak.
    OK, well it will come off tomorrow, I was concerned to about the texture of it and the bend, but thought it would be better then the stock box. Where to I get the kanaflex?

Page 1 of 6 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. does this seem about right on a 700?
    By rhino_160 in forum Yamaha Old School Skis
    Replies: 5
    Last Post: 08-26-2008, 11:10 PM
  2. does this look right?
    By rxpblast in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 10-21-2007, 08:24 AM
  3. Does this look right? SC impeller
    By JayG in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 05-17-2007, 06:15 PM
  4. Does this look right?
    By MikeB in forum 4-Tec Performance
    Replies: 16
    Last Post: 04-11-2007, 10:30 PM
  5. does this seem right
    By MONKEY in forum 4-Tec Performance
    Replies: 2
    Last Post: 06-11-2006, 12:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •