Results 1 to 6 of 6
  1. #1

    Join Date
    May 2008
    Location
    South Eastern Michigan
    Posts
    198

    RXP-X - Water in VTS motor normal???

    Hey everyone... really quick,

    Installing some parts right now. I had to remove the VTS motor, but when I did water came out of it. Prob. about a 1/4 cup. Some water even came out when I was removing the VTS rod (1/8th cup or so). Took the cover off of the motor housing and it's all wet in there.

    Nothing has been touched, until now. (factory original)

    Problem? Or forget about it and expect the VTS to fail in a year or two? Water doesn't get into the hull because the case cover for the VTS motor seals water tight with a rubber seal.

    -=Mike G.


  2. #2
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Dont worry about it . Every one I have pulled apart has water in it and usually about a cup of sand also.

  3. #3
    Whats that whistling noise? jtskier11's Avatar
    Join Date
    Sep 2007
    Location
    Right side of Kansas
    Posts
    4,342
    +1
    87
    Just to cover your ass......... Check the clamps on the VTS boot!! Make sure they are tight.

  4. #4

    Join Date
    May 2008
    Location
    South Eastern Michigan
    Posts
    198
    Quote Originally Posted by jtskier11 View Post
    Just to cover your ass......... Check the clamps on the VTS boot!! Make sure they are tight.
    Yeah... they were tight. None of it is on the ski right now (in the middle of doing Riva Exhaust and 15/22R.) Oh well... I've got the 5 year warranty that should take care of it.

    Shoot, I'll probably get rid of it for something else within' two years anyways (assuming something better comes out).

    -=Mike G.

  5. #5
    Dave Sharp dav_dman's Avatar
    Join Date
    Aug 2005
    Location
    louisville Ky/so. IN
    Posts
    1,453
    +1
    1
    the IC for the X sits on top the VTS doesn't it? could be a leaking water line connection.

  6. #6

    Join Date
    May 2008
    Location
    South Eastern Michigan
    Posts
    198
    Quote Originally Posted by dav_dman View Post
    the IC for the X sits on top the VTS doesn't it? could be a leaking water line connection.
    yeah, it does.. but the VTS housing is sealed. The only way water could get in would be from the outside (VTS Rod/boot). I have never seen water or even any traces of water inside my hull, and I look with a flashlight after every ride. I've got 23 hours on the ski and it still smells like new even.

    I'm gonna make sure it's on there good this time. Everything on the VTS seemed loose. Hell, I was able to undo the VTS nut with the VTS tool without even putting a screwdriver through the tool. I just twisted it off with my hands.



    -=Mike G.
    Last edited by Mikey G.; 07-20-2008 at 11:11 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: 05-30-2012, 04:39 PM
  2. Rxp-x water in oil and burning oil help
    By onelegman in forum 4-Tec Performance
    Replies: 9
    Last Post: 02-26-2012, 09:27 PM
  3. 05 rxp geting water in hull
    By RXP2 in forum 4-Tec Performance
    Replies: 1
    Last Post: 05-08-2010, 08:16 PM
  4. Got water in your motor?
    By xsockguyx in forum Open Discussion
    Replies: 3
    Last Post: 09-21-2009, 01:05 AM
  5. Water in the bilge normal?
    By atom1234 in forum Sea Doo Sport Boats
    Replies: 16
    Last Post: 05-02-2008, 05:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •