Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1
    GTI SE 155
    Join Date
    Sep 2007
    Location
    Houston
    Posts
    139

    GPS'd my GTI.....

    For the first time, I put the GPS on my '07 GTI SE 155. Fastest I could get it up to was 54.9......thought I'd get at least 58. Here are the details:
    Water and air temp around 90, 80% humidity, sea level (near shore bay of the Gulf of Mexico). 3/4 fuel, rider at 210 lbs, flat water. Is this to be expected? Any thoughts?


  2. #2
    Never Time To Ride antoniodef's Avatar
    Join Date
    Nov 2006
    Location
    Waterford, Michigan
    Posts
    1,169
    What RPM's?? I have the 130 and hit that. Ideal conditions supermanned though.

  3. #3

    Join Date
    Nov 2007
    Location
    Abilene, Texas
    Posts
    35
    thats about what I get on the two of mine...around 55 m.p.h. varies with conditions of wind, water, ect.

  4. #4
    GTI SE 155
    Join Date
    Sep 2007
    Location
    Houston
    Posts
    139
    7290-7300 rpm's
    Lazy D.....do you have the 155?

  5. #5
    Never Time To Ride antoniodef's Avatar
    Join Date
    Nov 2006
    Location
    Waterford, Michigan
    Posts
    1,169
    I'm only around 7200

  6. #6
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Out of curiousity what are the desired rpms for the 130,s and 155,s.

  7. #7
    italianstallion314's Avatar
    Join Date
    Oct 2007
    Location
    barnegat bay
    Posts
    434
    On a gti 155 SE, I know you should be going faster than that. The 130 GTI goes around that speed, the 155 should see high 50s.

  8. #8
    GTI SE 155
    Join Date
    Sep 2007
    Location
    Houston
    Posts
    139
    I'm getting the RPM's, at around 7300
    Might I have some kind of damage to the impeller? Would that result in a lower speed? I've driven through some crap when I first got the ski, but visual inspection shows nothing, and I get no unusual vibrations or anything. Seems to run fine!

  9. #9
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Your rpms should be closer to 7600 rpms. You might try taking out 2-mm from the trailing edge and see if that helps... Ron

  10. #10
    GTI SE 155
    Join Date
    Sep 2007
    Location
    Houston
    Posts
    139
    Ron, what do you mean, take out 2mm from the trailing edge?
    Also, are you getting 7600 rpm's?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. installing a handleld GPS on my 250X...
    By giguchan in forum Kawasaki Open Discussion
    Replies: 2
    Last Post: 09-29-2007, 02:28 AM
  2. Newbie & Want More Speed For My GTI
    By Flynfox in forum 4-Tec Performance
    Replies: 6
    Last Post: 08-10-2006, 11:22 AM
  3. Just GPS'd my 06 RXP, ye ha!!!
    By NeverEndn in forum 4-Tec Performance
    Replies: 18
    Last Post: 07-21-2006, 10:52 PM
  4. GPS'd my '03 after mods seems a little slow any ideas?
    By NateGP1300R in forum Yamaha PWC Performance (2-stroke)
    Replies: 21
    Last Post: 07-06-2006, 07:15 AM
  5. GPS for my RXP ?
    By cr1421 in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 04-12-2006, 08:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •