Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    race24x's Avatar
    Join Date
    May 2007
    Location
    Fayette, Maine
    Posts
    1,005

    Question 98 951 XPL

    I have been riding my 2 98 951's for some time now and wanted to ask a new questions.
    The XPL has a kit with filters runs great top end takes off real hard I know I have a bit of cavitation problem maybe wear ring or something because the thing hits rev limiter hard while taking off and at 7000 I am only running about 62 MPH on GPS. The weird part is in the middle. It almost feels like I can feel the rave valves open. Under 25 or so runs good maybe a bit rich way down but runs good. right at about 25 MPH if you push it just a bit harder it takes off like a rocket like the raves open up and it has all kinds of power. Its a transition thing you cant seem to go 30 MPH to save your life 25 or 35 but in between its weird it doesnt want to be smooth. I am trying to explain it best I can. Hopefully you guys know what I am talking about and have noticed it before and have a fix. FYI replaced all fuel lines cleaned carbs eliminated the fuel switch PRO K filters and different jets and pop spring I got from a guy on here. SKat track impeller that was in it when I bought it so dont know the pitch.


  2. #2
    PEST!'s Avatar
    Join Date
    Jun 2008
    Location
    Rockledge Florida
    Posts
    768
    First off trouble shoot with a tach not a speedo.. Speedo to subjective but tach tells about were the raves open and how the engine is doing carbs are done with how much throttle 1/4 1/2 3/4 WFO. Makes it easyer to find the issue. IF I understand the issue your bottom end seems a little ritch about 1/4 - 1/2 throttle but it goes like heck when you hit 1/2-3/4. Well you can play with jetting and change it a little but its the way those carbs and F/A's work . The F/A's reduce carb signal so they make up by lowering popoff and fattening up the jetting.. You can go back stock and it will get better but if you want a totaly linier throttle you will have to get a Fuel injected 4 stroke even the DI and RFI get a surge at 5k from the raves...

  3. #3
    race24x's Avatar
    Join Date
    May 2007
    Location
    Fayette, Maine
    Posts
    1,005
    No not looking for perfect just a bit better it seems to be in the crusing speed all my friends like to ride in LOL. Sorry I should have checked the Tach for better ranges. It bobbles a bit down low but nothing serious and never fouls a plug. It is more annoying than anything, but comes right out of it when you take it just above idle or just above a no wake zone speed. After that it seems good from there to about 1/2 throttle. That is where it seems to act like if you squeeze it just hair more its liek the rave valves open (or something like that) and it takes off like a rocket. Similar to a normal 2 stroke dirt bike or something. You give it just a bit more throttle and its in the power band. It is just very noticeable and I thought there might be an adjustment off or something.

  4. #4
    race24x's Avatar
    Join Date
    May 2007
    Location
    Fayette, Maine
    Posts
    1,005
    T

  5. #5
    Master of the Dooniverse
    Join Date
    May 2006
    Location
    Schenectady, Ny
    Posts
    597
    that's about where the raves open up though.....i always loved that on SkiDoo sleds. that pull is the best.....love thos epower valves. there's two positions unless you have E-raves, which no SeaDoos do. open and closed is all you get.

  6. #6
    yours is not the only one. mine does the same thing and i am all stock. 98 xpl with 951. at a certain point the things just rockets forward. let off just a hair and it fall on its face again. squeeze ever so slightly and there she goes again. pretty weird i always thought. but i came from riding a 96 gti with 717 big differance all the way around.

  7. #7
    I don't seem to have that problem but my RPM's and speed are a bit less than your. I never exceed 7000 RPM and my speed is around 58-59.

  8. #8
    race24x's Avatar
    Join Date
    May 2007
    Location
    Fayette, Maine
    Posts
    1,005
    I checked this weekend and found issue was about 4800 RPM not sure where the valves open but at that RPM its pretty apparent. I am going to try going one way or the toher with the red caps on the rave valves and see if that makes it a bit better or less apparent. Like the power though

  9. #9

    Join Date
    Mar 2008
    Location
    Perth wester Australia
    Posts
    111
    Hi

    You will find you raves normally open a fair bit higher than that.. it sounds like its your pop offs.. sounds like its leaning out on the lows than the highs come on and your off like a rocket.. mine does the same...

    You can get it a little better by dropping pop offs but when you start to play around with the XPL i have never seen them run smooth over the range (unless you have a week of spare time and dont mind pulling the carbs off 20 times until its right)

  10. #10

    Smile

    "I know I have a bit of cavitation problem maybe wear ring or something because the thing hits rev limiter hard while taking off and at 7000 I am only running about 62 MPH on GPS. The weird part is in the middle. It almost feels like I can feel "OK its not jetting its a combination of problems,first off its a pump problem if it hits rev limiter hard at take-off,whether thats just your pump sucking air,or not sealed ,or too much clearance, or a dinged impeller,the hit in midrange right at good cruising speed is caused by your raves opening, you can adjust the spring pressure and move the hit up or down a few hundred rpm by adjusting tension on preload springs just unscrew the red plastic inner adjustment , out if you want it to hit sooner or in if you want it to hit a bit higher, I had to do this for a guy who pulls his son on ski and wakeboard ,it was a 951gtx limited and they were opening exactly where he wanted to cruise, so it surged ,I tightened the red inner adjustment down and it moved the rave opening up a few hundred rpm ,just enough to not be a pain.HOPE this Helps>Marvin

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB - Parts WANTED:98 951 xpl coupling and coupling flange assy.
    By nikko mercado in forum Sea Doo 2 Stroke Skis
    Replies: 1
    Last Post: 08-14-2012, 01:06 PM
  2. Wanted 951 XPL 98 performance pipe
    By Sparkie in forum 2-Stroke Performance
    Replies: 2
    Last Post: 08-20-2009, 12:00 AM
  3. 951 Xpl 98
    By kowekiller in forum 2-Stroke Performance
    Replies: 7
    Last Post: 09-28-2008, 11:23 AM
  4. New to GH with some questions?951 XPL
    By kowekiller in forum 2-Stroke Performance
    Replies: 3
    Last Post: 09-27-2008, 11:36 AM
  5. WTB 49cc head for 98 951 XPL and impeller
    By race24x in forum Sea Doo Classifieds
    Replies: 4
    Last Post: 07-29-2008, 08:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •