Results 1 to 4 of 4
  1. #1

    03 GTX with New S/C ... Still down on RPMs and Speed..?

    I have an 03 GTX S/C that i recently replaced the S/C with a new one. The old one the clutch went out on... but the washers didnt get washed in the engine. So i put the new s/c on , a new wear ring, and a new prop. I am only getting 7050-7120 rpms and only gps'ing 58-60mph. Not sure what problem is... Any help is appreciated!


  2. #2

    Join Date
    Aug 2005
    Location
    Salinas CA
    Posts
    451
    Quote Originally Posted by Fast05RXP
    I have an 03 GTX S/C that i recently replaced the S/C with a new one. The old one the clutch went out on... but the washers didnt get washed in the engine. So i put the new s/c on , a new wear ring, and a new prop. I am only getting 7050-7120 rpms and only gps'ing 58-60mph. Not sure what problem is... Any help is appreciated!
    Did you test the clutch pre-load spec. If it`s low. it will slip and cause your type of problem. Pull the S/C and test the pre-load.

  3. #3
    Cant I do that by locking the cam, and testing the end bolt inside of the S/C impeller rather than pulling the whole S/C ?

  4. #4
    Red Devil's Avatar
    Join Date
    Apr 2005
    Location
    Chesterfield/Richmond, VA
    Posts
    1,809
    Quote Originally Posted by Fast05RXP
    Cant I do that by locking the cam, and testing the end bolt inside of the S/C impeller rather than pulling the whole S/C ?
    Yes, or you can put a thin broom handle through the pump and impeller to lock it that way. As long as the impeller can't turn, you'll get an accurate reading as well.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 03 gtx with 04 Rxp prop
    By tomkun in forum 4-Tec Performance
    Replies: 9
    Last Post: 06-04-2017, 08:58 PM
  2. help with new engine install.... 1st start on xlt 1200
    By DieselNaz in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 08-17-2015, 01:17 AM
  3. 14 310r still down on rpms... Any ideas?
    By H20mxracer223 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 4
    Last Post: 04-20-2015, 06:08 AM
  4. 03 gtx di - new to me keeps beeping
    By nigel_miguel in forum 2-Stroke Performance
    Replies: 4
    Last Post: 07-17-2012, 09:46 PM
  5. 03-04 stg 2 1300 guys, Whats you're rpms and what prop?
    By slow1300 in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 01-08-2006, 09:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •