Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
  1. #1
    rxpblast's Avatar
    Join Date
    Jun 2005
    Location
    Ocean City, MD
    Posts
    2,113

    rpm's STILL to low

    went riding today with Brian and his SC ltd and he was beating me and i have an RXP with mods on it. RPM's were only 7700 in 84 water and 83 air. then in 73 water and 83 air i was at 7800-7850. i just cant figure out whats going on. my mods are as followed:

    Riva grate
    custom air intake
    Riva SC impeller
    ride plate holes filled
    free flow exhaust
    RE blockoffs
    14/19 impeller
    and some other things that don't matter with speed.

    oil is perfect and just put a new wear ring in. any ideas would be greatly appreciated.
    Last edited by rxpblast; 07-21-2006 at 11:49 AM.


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    are you cavitating out of the hole?

  3. #3

    Join Date
    Aug 2005
    Location
    Salinas CA
    Posts
    451
    Quote Originally Posted by rxpblast
    went riding today with Brian and his SC ltd and he was beating me and i have an RXP with mods on it. RPM's were only 7700 in 84 water and 83 air. then in 73 water and 83 air i was at 7800-7850. i just cant figure out whats going on. my mods are as followed:

    Riva grate
    custom air intake
    Riva SC impeller
    ride plate holes filled
    free flow exhaust
    RE blockoffs
    14/19 impeller
    and some other things that don't matter with speed.

    oil is perfect and just put a new wear ring in. any ideas would be greatly appreciated.
    Mine is the same. 63 MPH at 7700 RPM max. If I find the cause, I`ll let you know. If you fix it first, let me know.

  4. #4
    rxpblast's Avatar
    Join Date
    Jun 2005
    Location
    Ocean City, MD
    Posts
    2,113
    Quote Originally Posted by Green Hulk
    are you cavitating out of the hole?
    Jerry its caviating a little bit.

  5. #5
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Check the wear ring, carbon seal, pump seal

    Also, how many RPM's with the stock prop?
    Last edited by Green Hulk; 07-21-2006 at 02:12 PM.

  6. #6
    rxpblast's Avatar
    Join Date
    Jun 2005
    Location
    Ocean City, MD
    Posts
    2,113
    wear ring doesn't look that bad. i did notice a slight nick in one of the blades of the prop though. how do i check the seals, what will they look like if there bad?

  7. #7
    rxpblast's Avatar
    Join Date
    Jun 2005
    Location
    Ocean City, MD
    Posts
    2,113
    also found the intake grate is loose on one side. a bolt broke when we took it off so we siliconed it to hold it in place but now im wondering if at high speed that side of the grate is flexing at all.

  8. #8
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Fix that grate!

    As far as the pump seal. Sometimes they can get a bit pinched and will leak air (cavitate)

  9. #9
    rxpblast's Avatar
    Join Date
    Jun 2005
    Location
    Ocean City, MD
    Posts
    2,113
    ok, im going to check that next! thanks Jerry. i guess a nick in the prop isn't good either huh?

  10. #10
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    a tiny knick won't affect it.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 05 RXP another Low RPM"S 7600 to 7700
    By joewharton2 in forum Sea Doo Open Discussion
    Replies: 21
    Last Post: 07-14-2011, 07:20 PM
  2. any suggestions? same rpm lost 5-7 mph from almost 90 to low 80s same rpm
    By green08 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 08-30-2010, 08:40 PM
  3. Is this a scam? Seam to low
    By texoma in forum Yamaha PWC Performance (4-stroke)
    Replies: 7
    Last Post: 07-20-2008, 03:30 PM
  4. NEW 250's at Prices to low to post
    By prochamp in forum Kawasaki Classifieds
    Replies: 8
    Last Post: 06-28-2008, 10:01 PM
  5. i gained 450+ rpms from 81mm to 82mm
    By Shibby1485 in forum 4-Tec Performance
    Replies: 25
    Last Post: 04-27-2006, 09:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •