Results 1 to 3 of 3

Thread: 2000 gp 1200

  1. #1

    2000 gp 1200

    Not sure if Im posting in correct spot,have a 2000 gp 1200 that has a new top end replaced.Engine runs fine for short period then seems like it goes into a limp mode,runs but lacks power,let it sit for awhile and it will run fine for a bit longer.please help!!!!


  2. #2

    Thumbs up Re: 2000 1200...

    Sounds like a catalytic converter problem. When they over heat they go into a limp mode. Once it cools off it`ll run ok for awhile-Mark

  3. #3
    Ramps's Avatar
    Join Date
    Jan 2008
    Location
    Myakka, FL
    Posts
    649
    +1
    28

    +1

    Quote Originally Posted by GigHarborPWC View Post
    Sounds like a catalytic converter problem. When they over heat they go into a limp mode. Once it cools off it`ll run ok for awhile-Mark
    Ditch the cat and install sensor chip..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 gp 1200 carb help
    By bwimmer29 in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 05-08-2015, 02:29 PM
  2. FS 2 Waverunners 2000 GP 1200 R & 2001 XLT 1200 R
    By mudslanger in forum Yamaha 2 Stroke Skis
    Replies: 2
    Last Post: 01-28-2015, 07:25 PM
  3. 2000 GP 1200 feels heavy ??? Hull Problem
    By gp1200rider in forum Conversion PWC Performance Skis
    Replies: 12
    Last Post: 10-21-2014, 10:40 PM
  4. 2-Stroke 2000 GP 1200 engine removal
    By ryanwoodard in forum Yamaha Projects & Build Threads
    Replies: 6
    Last Post: 01-16-2013, 11:27 AM
  5. Looking For Styrofoam for rear of 2000 GP 1200...
    By GigHarborPWC in forum Yamaha Classifieds
    Replies: 3
    Last Post: 07-26-2008, 05:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •