Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 29
  1. #1

    Join Date
    Apr 2007
    Location
    Jacksonville, FL
    Posts
    756
    +1
    2

    need help with my gprxp

    I have a gprxp that will not go faster than 75 mph.

    My mods are

    xs intercooler
    stg3 charger
    42 lbs injectors
    4 in intake
    stock 01 pump
    14/20 concord
    riva ride plate
    beach house sponson
    rpms 7900

    Im just looking for a little help
    thanks Cliff


  2. #2
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    Any strange symptoms? Does it sound smooth, any stumbling on the top end?

    If you are overpropped it will never achieve top speed. Have you MEASURED that prop? I have a known 13/19 laying around you can try.

  3. #3
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    Also, some pictures of your handling, rideplate, intake grate and pump shoe might be a smart thing.

    You might need to determine if this is a Yamaha hull issue, or a SD engine issue.

  4. #4

    Join Date
    Apr 2007
    Location
    Jacksonville, FL
    Posts
    756
    +1
    2
    motor sound strong theres no boggin motor only has 52 hrs on it.boost gauge reads 9-10 but as far as the hull their has been no shimming no pump shoe kit or anything. i had jim at jims performance work on the prop to get my rpms where they are now

  5. #5

    Join Date
    Apr 2007
    Location
    Jacksonville, FL
    Posts
    756
    +1
    2
    i dont even have a clue how fast it should be with my setup

  6. #6
    Moderator Insanediego Joe's Avatar
    Join Date
    Mar 2006
    Location
    San Diego, California, United States
    Posts
    5,885
    +1
    142
    Should be in the mid to high 80s.....What ride plate are you running? After market trim tabs? What diameter exit nozzle are you running? Need to know your entire set up before we can help you... I have a little less horse power than your set up and my best so far has been 88.1 mph.

  7. #7
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    807
    Joe, don't forget you have the Riva ECU and a better pump with a Dynafly. I know that's not worth 13 mph, but it's worth noting.

    I'd be willing to bet between all the hull components there's a solid 6+ mph being lost. 1200 grate? stock Riva plate? Old pump is slower than new pump with Dynafly. Intake grate matched with pump shoe? Pump shoe is sealed? No shims....there are dozens of reasons why you are slower than you should be.

    While you're getting the hull fixed up make sure your engine components are good. Have the prop tweaked to get 8100 RPM then note boost. If it's not 10-11 psi then you should check the slip moment on the supercharger. Make sure your intercooler is not leaking. To do that you can take the pipe off that goes from the intercooler to throttle body. Run the ski and see if water starts pouring out of the intercooler.

  8. #8

    Join Date
    Apr 2007
    Location
    Jacksonville, FL
    Posts
    756
    +1
    2
    thanks guys for the help but im going to take it to jims performance and let him get the hull set up correct

  9. #9
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    Joe was mid-80's with a stock ECU. He's a "tad" faster now.

    If you are taking your ski to Jim, then have him TEACH you how to set up the hull, so that you can progress further.

  10. #10

    Join Date
    Apr 2005
    Location
    Jax,FL
    Posts
    2,677
    +1
    24
    Very Smart Move Cliff=d> I Guess I Need To Work On My Ski So I Can Try To Keep Up? Maybe I Can Ride With The Big Boys Todd

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Parts needed. Help with my RXP build
    By caliburst in forum Sea Doo Classifieds
    Replies: 30
    Last Post: 11-03-2008, 06:19 PM
  2. Need help with my GP1200!
    By MTAINFLA in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 03-28-2008, 02:13 PM
  3. Need help with my C180
    By Atlantis in forum Sea Doo Sport Boats
    Replies: 5
    Last Post: 09-12-2007, 08:46 PM
  4. Need help with my 1050 mph
    By 1FASTXC in forum Polaris Open Discussion
    Replies: 32
    Last Post: 06-09-2007, 02:05 PM
  5. Need Help with my STLX 1050
    By Johnquest in forum Polaris Open Discussion
    Replies: 18
    Last Post: 03-15-2007, 10:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •