Results 1 to 9 of 9
  1. #1
    Banned User
    Join Date
    Jul 2006
    Location
    Ft.Lauderdale
    Posts
    3,237

    RXP Problems,Please advise!!

    I have a '06 Rxp with stage II,After install of Stage II I never got the Top end I was looking for, I've read that the Solas Impellar could need a tweak to regain lost RPM? Do you guys agree?
    Like others I've also had the overheating problem and my mechanic felt that removing the water restriction washer leading to the exhaust would help and it did but it seems to have lost alot of speed and more RPM!!!( When checked by GPS it was reading maybe 64MPH at best and 7250 RPM. I'll go back and flush the intercooler,should I replace the Washer?
    Please help me regain my speed!!!!!!
    Thanks guys..


  2. #2

    Join Date
    Jun 2006
    Location
    toronto
    Posts
    965
    What pitch prop are you running?

  3. #3
    Banned User
    Join Date
    Jul 2006
    Location
    Ft.Lauderdale
    Posts
    3,237
    15/20
    Last edited by Alex13; 07-23-2006 at 07:12 PM.

  4. #4
    way2fast's Avatar
    Join Date
    May 2005
    Location
    Melbourne Beach, FL
    Posts
    4,009
    +1
    4
    Stage 2 requires a 15/20

  5. #5
    Banned User
    Join Date
    Jul 2006
    Location
    Ft.Lauderdale
    Posts
    3,237
    I checked and it's a 15/20

  6. #6

    Join Date
    Jun 2006
    Location
    toronto
    Posts
    965

    1520

    Are you guys sure that all Stage II's can push 15/20 pitched prop. I was under the impression that depending on the set-up some of them could not push one to potential.

  7. #7
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    u completely removed the restriction washer for the water inlet for the pump?

    i think it needs to be there

  8. #8
    Banned User
    Join Date
    Jul 2006
    Location
    Ft.Lauderdale
    Posts
    3,237
    I didn't but it was removed looking for the overheating problem, it did fix the problem or I guess cover it up.

  9. #9
    Banned User
    Join Date
    Jul 2006
    Location
    Ft.Lauderdale
    Posts
    3,237
    After some reading I found that it could be very bad.
    Who could help me with the impeller in the Ft. Lauderdale area?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Huge Virage i problem please advise
    By wallflood in forum Polaris Open Discussion
    Replies: 12
    Last Post: 08-08-2015, 05:53 PM
  2. 07 rxp problem please help
    By honda1k in forum 4-Tec Performance
    Replies: 1
    Last Post: 05-11-2015, 05:02 AM
  3. 07 rxp problem please help
    By honda1k in forum Open Discussion
    Replies: 2
    Last Post: 05-11-2015, 12:10 AM
  4. 2007 RXP Problem! Please Help
    By Ericc in forum 4-Tec Performance
    Replies: 10
    Last Post: 06-11-2007, 10:33 AM
  5. '05 Rxp Problem Please Help
    By WannabeGoing80 in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-16-2006, 03:02 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •