Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 50
  1. #1
    Hydrotherapy's Avatar
    Join Date
    Sep 2006
    Location
    The Rock
    Posts
    3,347
    +1
    17

    ported skis dead

    guys what do you think happened here..

    on home run back to ramp and she locked up while WOT..

    mega heat shown on bottom of rod and metal slither sticking out the side between thrust washer(marked with pencil)

    piston eaten up a bit and rings not moving as you would expect,no wash on piston but i think it was due to heat..

    #2 big end is solid and rod jammed real good and not moving at all,but looking at it with the piston out the rod looks offset like the ends have failed and locked it all up

    looks as if there is damage on botton crank case but checking that out soon..

    not able to post pics yet
    Last edited by Hydrotherapy; 07-24-2008 at 05:19 PM.


  2. #2
    Hydrotherapy's Avatar
    Join Date
    Sep 2006
    Location
    The Rock
    Posts
    3,347
    +1
    17
    pics
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	blown 05 second pics 001.jpg 
Views:	79 
Size:	2.87 MB 
ID:	84919   Click image for larger version. 

Name:	blown 05 second pics 002.jpg 
Views:	89 
Size:	3.29 MB 
ID:	84920  

  3. #3
    Never say never KirkF350's Avatar
    Join Date
    Jun 2005
    Location
    Midlothian, Texas
    Posts
    4,433
    +1
    3
    Oh man. That sucks.

  4. #4
    Hydrotherapy's Avatar
    Join Date
    Sep 2006
    Location
    The Rock
    Posts
    3,347
    +1
    17
    cant load pics and pc just about to land in garden

  5. #5
    Hydrotherapy's Avatar
    Join Date
    Sep 2006
    Location
    The Rock
    Posts
    3,347
    +1
    17
    pics
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	blown 05 second pics 005.jpg 
Views:	74 
Size:	3.29 MB 
ID:	84921   Click image for larger version. 

Name:	blown 05 second pics 006.jpg 
Views:	84 
Size:	2.81 MB 
ID:	84922  

  6. #6
    Hydrotherapy's Avatar
    Join Date
    Sep 2006
    Location
    The Rock
    Posts
    3,347
    +1
    17
    few more

    sorry guys cant sort the pics out its a bad day all over lol..
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	blown 05 second pics 005.jpg 
Views:	69 
Size:	3.29 MB 
ID:	84923   Click image for larger version. 

Name:	blown 05 second pics 006.jpg 
Views:	57 
Size:	2.81 MB 
ID:	84924  

  7. #7
    james k's Avatar
    Join Date
    Aug 2007
    Location
    Panama City Beach,FL
    Posts
    950
    +1
    1
    Man Hydro,that sux big....I am very sorry to hear this happened to you...

  8. #8
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    Looks like a crank bearing died.

  9. #9

    Join Date
    Nov 2005
    Location
    Charleston, SC
    Posts
    374
    looks to me like the oil pump failed, also looks lean
    Mike

  10. #10
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    Quote Originally Posted by Hydrotoys View Post
    Looks like a crank bearing died.
    +1


Page 1 of 5 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS NC 2004 Gp1300R 80mph ported ski complete or engine parts
    By Avi8tor in forum Yamaha Classifieds
    Replies: 10
    Last Post: 08-05-2012, 06:43 AM
  2. TEXAS E.F.I SKI BREAKS LOOSE !! NO PORTING!!
    By Knr in forum Yamaha PWC Performance (2-stroke)
    Replies: 31
    Last Post: 08-22-2008, 06:51 PM
  3. lowell ported ski...should i do exhaust mod?
    By MJE in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 06-21-2008, 10:02 PM
  4. Porting for non powervalve ski.
    By porksword in forum Yamaha PWC Performance (2-stroke)
    Replies: 22
    Last Post: 03-06-2007, 08:01 PM
  5. Ported and / or Big Bore ski's
    By GPR FL in forum Yamaha PWC Performance (2-stroke)
    Replies: 23
    Last Post: 03-27-2006, 01:32 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •