Results 1 to 4 of 4
  1. #1

    Problems with 05 RXP

    Hello, I'm new to this site but glad I found it. My problem is I purchased a 05 rxp took it out wouldn't go over 34 mph. After reading postings on this site I was convinced it was the supercharger, so I purchased a rebuild kit online and took machine to only seadoo dealership in area. They call me today and tell me that the ceramic washers are still intact and the shaft and bearings are still good. I asked them why it would only go that 34mph they said they dont know. So they are gong to swap washers for me. Is there anything else I can ask them to check. Compression test was done when I first bought it and readings were ok. Any feedback is greatful.


  2. #2
    Masterz's Avatar
    Join Date
    Jun 2008
    Location
    Watson, LA
    Posts
    219
    +1
    1
    did you test drive it before you purchased it? How long ago did you purchase it? I would be contacting the seller about this issue, it was obvious there was a problem when you purchased it.

  3. #3
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Were you using the white key/lanyard?

  4. #4
    Masterz's Avatar
    Join Date
    Jun 2008
    Location
    Watson, LA
    Posts
    219
    +1
    1
    Quote Originally Posted by speedskixp View Post
    Were you using the white key/lanyard?

    good call, I wasnt even thinking of that....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problems With My RXP
    By W35LEY in forum 4-Tec Performance
    Replies: 19
    Last Post: 07-12-2007, 12:45 PM
  2. Still have a problem with my RXP.....
    By LiquidDI in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-04-2006, 01:18 AM
  3. Newbie to the site with 05 RXP
    By fenderu2 in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 04-22-2006, 09:58 PM
  4. OMG Problem with my rxp and myself!!!!
    By ADAMBOMB in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 04-20-2006, 09:55 AM
  5. Found my Problem with My RXP after Service.
    By Water4fire in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-20-2005, 03:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •