Results 1 to 5 of 5
  1. #1

    Unhappy Need Help Please.........

    Hello everyone,

    I have a 97 polaris Hurricane 700, It's my first jet ski and I dont know much about them.
    I put it in the water and it starts good and runs good (for a minute)
    After about a minute it just quits, it will start right back up and go alittle ways and do the same thing but it always starts back up.
    Someone told me it was the inline filters so i replaced them and it still does the samething, Then someone told me it was the fuel pump well i dont know where the fuel pump is or even know if its bad or not...

    If anyone can help me I would greatly appreciate it..


  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Cleveland OH
    Welcome to the Hulk.

    You have Keihin carbs on that ski.

    The fuel pump is integrated into the carbs.

    Might I suggest getting your carbs rebuilt before you damage the pistons.

    Randy at can service them for you. Or you can try it yourself with a little help of course. I'd also recommend new fuel hoses as they are probably pretty old.

  3. #3
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Campbell, Ca.
    Pull the carbs and clean them (fuel pumps are attached to the carbs). Replace the crappy fuel lines. Make sure the fuel tank is clean.

  4. #4
    Thanks for the welcome and thanks for your help, I'll try cleaning the carbs and replace the fuel lines.

    Thanks again....

  5. #5
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Cleveland OH
    If your ski is all stock the screw adjustments are in the tech section or in the manual.

    If it's been modified, I'd record the settings you presently have on them, and return them there after re-assembly.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. new to polaris need help please
    By pepp101 in forum Polaris Projects
    Replies: 22
    Last Post: 07-30-2007, 02:15 PM
  2. 96 SL900 Uh Oh Need HELP Please
    By christian79 in forum Polaris Open Discussion
    Replies: 12
    Last Post: 07-16-2007, 11:58 PM
  3. Need Help Please!!!!!! On Prop Choice
    By MB VIP in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 07-10-2007, 08:41 AM
  4. Need HELP Please!
    By GeoRXT in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-30-2006, 08:04 AM
  5. HEy Guys Need Help PLEASE!!!
    By SpeedStang95 in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-06-2006, 01:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts