Results 1 to 6 of 6

Thread: Whirring sound

  1. #1

    Join Date
    Mar 2008
    Location
    Lexington KY
    Posts
    6

    Whirring sound

    I have an 08 Green Ultra 250x. No mods. Total hours ~30. The last 5 hours or so have 'sounded' different than the first 25 hours. The only way to explain it is that it sounds like a whir in the lower rpms but after its about 4000 it sounds just like it did before and the whir mixes in with the regular engine sound.

    No loss of acceleration, i get full boost bars, and i still get my top end. I brought it to the dealer immediately after I heard it and they found nothing. They said after the season is over they will investigate more but not to worry about it for now (unless the sound changes or performance loss occurs).

    Has anyone else had this issue? If so, same symptoms? Or is my engine just getting worn in?

    I'd love to hear anyone's thoughts. Thanks!


  2. #2
    gregt909's Avatar
    Join Date
    Jun 2008
    Location
    Montgomery Texas
    Posts
    64
    I know I'm not answering your question but do you have a hitch attached to your boat trailer to pull your Jet Ski? That is so cool. I've never seen that before.

  3. #3
    Sounds like your pump bearings are headed south . . . . The Ultra 150 was famous for this. It is not that big a deal to have them changed at the dealer; I do believe special tools are required.

    Ditto the last Post . . . cool Rig you got there! jb

  4. #4

    Join Date
    Mar 2008
    Location
    Lexington KY
    Posts
    6
    Thanks for the suggestion, I'll have my dealer check into it. It is only a few months old so I'm having them perform all work on it at this point.

    I had a local trailer and hitch company fabricate an additional beam to follow the form of the other boat trailer cross members. This beam bolts on to each side of the trailer, and at the bottom of this new beam, a hitch receiver is welded to both the existing back beam and the new fabricated beam. I put a standard extended 2" drop ball hitch, reverse, so that the ski trailer sits level. I remove the hitch insert with ball before every launch/retrieval.

    I do have to mind super steep hills so that my boats outdrive doesnt hit the ski's trailer. I also avoid any situation where I would need to back up.

    We used to have to use two tow vehicles, which sucks. Twice the amount of gas, and the family gets split up. So, at the price of a little more hassle at the launch ramp, we get to drive to the lake together and save on fuel costs. Check with your state laws, many state's do not allow this sort of setup. Luckily, Kentucky does. I see a few other rigs setup like mine, and behind different types of boats too. It does get some stares.

  5. #5
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,162
    +1
    602
    Quote Originally Posted by john belton View Post
    Sounds like your pump bearings are headed south . . . . The Ultra 150 was famous for this. It is not that big a deal to have them changed at the dealer; I do believe special tools are required.

    Ditto the last Post . . . cool Rig you got there! jb
    http://www.greenhulk.net/forums/show...&postcount=326

    I dont like whirring noises,
    Waz

  6. #6
    JET250's Avatar
    Join Date
    Jan 2008
    Location
    Australia mate fair dinkum.
    Posts
    1,278
    +1
    2
    replace your pump bearings asap. will save you much pain and a new motor.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Whirring sound in water, won't go???
    By hstrine3 in forum 2-Stroke Performance
    Replies: 14
    Last Post: 08-25-2015, 11:38 AM
  2. 2006 RXP whirring sound
    By Sea Dood in forum 4-Tec Performance
    Replies: 6
    Last Post: 07-29-2012, 11:56 AM
  3. I want my RXP to sound like this.. hahaha
    By VFX_Artist in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 08-14-2005, 10:05 PM
  4. Wake jumping and crashing sound!!
    By Kinchyle in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-17-2005, 12:19 PM
  5. sound improvment (louder) on RXP ?
    By mrracing in forum 4-Tec Performance
    Replies: 23
    Last Post: 05-05-2005, 05:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •