Results 1 to 3 of 3

Thread: 99 gtx

  1. #1

    99 gtx

    i have a 99 gtx and when we put in the key nothing happens it doesnt beep or show that theres any flow of electricity, but there is power in everything. a fuse was blown but all we did was put another one in and we keep blowing all of them. what should we do to solve our problem?????? PLEASE HELP!!!

  2. #2
    96XPSS's Avatar
    Join Date
    Feb 2006
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    There are different size fuses for different circuits. It would be helpful to let us know which size is blowing so we can advise what component is connected to that particular fuse.


  3. #3

    99 gtx reply

    it is the 15 amp in the ign box and a 3 amp in the front electric box

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. '05 RXT/GTX RR IC install question... O-ring?
    By 05Limited in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-03-2005, 09:54 AM
  2. A few pics of my almost finished 03 GTX sc
    By two2curupt in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-20-2005, 09:54 AM
  3. Can I post GTX stuff
    By two2curupt in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-14-2005, 10:54 PM
  4. adding external intercooler to 2003 gtx sc motor
    By rapidacceleration in forum 4-Tec Performance
    Replies: 12
    Last Post: 05-12-2005, 08:17 AM
  5. Break in period and Noise at 5000rpms on 05 GTX Limited
    By spc9669 in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-08-2005, 11:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts