Results 1 to 10 of 10
  1. #1

    95 xp 800 ELECTRICAL part

    part out of 95 xp 800 rear elec box it 1 1/4x3/4 inch has red wire from Starter Relay and red from Harness can't find it in parts manual.


  2. #2
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    What are you asking? Where they go or how to get a replacement? You missed a few words there...

    Welcome!

  3. #3
    No, I don't know what it is. I broke it trying to clean it.

  4. #4
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    It's a fuse block. Pull the caps off and look inside...

  5. #5
    here is a picture of the part. Please look at it and if you know what it is and what is does, let me know. Thanks
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DSC01989.JPG 
Views:	49 
Size:	111.4 KB 
ID:	85310  

  6. #6
    Master of the Dooniverse
    Join Date
    May 2006
    Location
    Schenectady, Ny
    Posts
    597
    that don't belong in there......that's not OEM. looks like some cheap azz realy that's not made for wet service.

  7. #7
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Quote Originally Posted by The Wayniac View Post
    that don't belong in there......that's not OEM. looks like some cheap azz realy that's not made for wet service.
    +1

    How bout a pic of the whole innards of the black box?

  8. #8
    Mystery part wires come too dead end !!!! VTS wired directly to battery is that ok? Here the inside of black box..
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DSC01994.JPG 
Views:	47 
Size:	152.3 KB 
ID:	85505  

  9. #9
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Thanks. It looks like they remote mounted a terminal? Hmm...one of your fuses are missing. One should be 15 amp that feeds the front gray box, and the other is 7.5 amp for the VTS. OK to direct connect to the battery. It needs to be fused though...I'd add a new socket.

    Clean all the corrosion on your gound post where all the black wires join. It can affect your performance. Also pull the plug in the top and verify the pins aren't corroded.

  10. #10

    Join Date
    Jul 2008
    Location
    Southeast Texas
    Posts
    101
    That mystery part is a self resetting automotive 12v circuit breaker. It was probably put in to replace either the main fuse (15A) or the VTS fuse (7.5A). I suspect the original owner got tired of replacing fuses, or, the OE fuse holder was bad. Either way, get that circuit breaker outta there and put the proper fuses back in. If it starts blowing the fuse(s), you have a electrical problem (short) somewhere.
    Robert V

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS - Parts 95 XP 800 Parts ,Hump seat,set back pump and hood
    By Seadooracer9 in forum Sea Doo 2 Stroke Skis
    Replies: 4
    Last Post: 10-21-2016, 05:59 AM
  2. Parts for sale - 787 - 95 XP 800
    By frohboy33 in forum 2-Stroke Performance
    Replies: 27
    Last Post: 07-01-2013, 06:44 PM
  3. FS Parting out 95 xp 800...
    By Toystore69 in forum Sea Doo Classifieds
    Replies: 6
    Last Post: 09-21-2011, 02:40 PM
  4. FS Parting out 95 xp 800
    By mitch411RXP in forum Sea Doo Classifieds
    Replies: 3
    Last Post: 10-10-2009, 07:30 AM
  5. Need Parts asap! 95 xp 800
    By gorilla03 in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 05-03-2009, 08:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •