Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17

Thread: check engin?

  1. #1

    Join Date
    Apr 2008
    Location
    Blaine,MN
    Posts
    72

    check engin?

    i have a 04 rxp with metal washers..im having a problem with my ski..when ill be riding either full blast or just letting it idle in the no wake zones..after awile it will have a loud beep and says check engin..motor runs fine untill about 3/4 the way throttle.(wont let me give it full)...but when in unplug the key and start it again its fine for awile then all of a sudden it comes on.

    I noticed alot of pressure in the dipstick. and steaming. oil level is fine but i just changed it with casterol gtx 10-40. and a new filter.

    any ideas? either on the skii or on where to get the code reader for it?


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    press the "set" button 5 times in a row and it will give you the P code on the display.

  3. #3
    Sick Puppy's Avatar
    Join Date
    Apr 2008
    Location
    Antigua Caribbean
    Posts
    38
    Sounds like your TOPS valve is not oppening to let the engine breath. I had the same prob, blanked off the TOPS valve and the ski ran great.

  4. #4

    Join Date
    Apr 2008
    Location
    Blaine,MN
    Posts
    72
    hey i pressed the button 5 times and all that shows up on the screen is End.

    am i doing it wrong?

  5. #5
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    You need to hit the Set button while the alarm is active. Once you stop the engine, the alarm information is gone... Ron

  6. #6

    Join Date
    Apr 2008
    Location
    Blaine,MN
    Posts
    72
    ok ill try it thank you

  7. #7

    Join Date
    Apr 2008
    Location
    Blaine,MN
    Posts
    72
    ok i got P-1202

  8. #8
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by trespasser_101 View Post
    ok i got P-1202
    That is : Oil tank pressure switch implausable or blow by valve still closed.

    Possible causes: Damaged oil pressure switch,Blow by valve failure or damaged circuit wires,conector or damaged ECM pins..

  9. #9

    Join Date
    Apr 2008
    Location
    Blaine,MN
    Posts
    72
    any pics on to where those might be? yes im sorry im not too good at the skiis but im learning.

    how would i fix it? ski seemed to run fine till the oil change.

  10. #10

    Join Date
    Apr 2008
    Location
    Blaine,MN
    Posts
    72
    i take i'm screwed? 5hrs since my last post no responds..

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. mod ecu on o5 rxp- check engine, knock sensor
    By friebe1 in forum 4-Tec Performance
    Replies: 4
    Last Post: 12-27-2011, 02:25 AM
  2. why does check engine come on
    By macattack in forum 4-Tec Performance
    Replies: 6
    Last Post: 08-01-2005, 10:16 PM
  3. check engine light came on when i went down to sea level
    By macattack in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-01-2005, 02:00 PM
  4. Check Engine Light
    By meeper in forum 4-Tec Performance
    Replies: 6
    Last Post: 07-27-2005, 04:24 PM
  5. Getting "Check Engine" message on 04 RXP
    By Jrsrxp in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-20-2005, 01:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •