Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12

Thread: 951 Pump Oil

  1. #1

    951 Pump Oil

    Hey everyone,

    After a great day of riding on saturday albeit the dirty carbs, some water got un the hull when i put it in on sunday, and now it wont run right. I pulled the plugs and got the little bit of water that was in the carbs out, and had it running on the trailer fine. However, in the water ive lost about 1000 rpm and its making a loud squeaking noise and it sounds like its coming from the back of the boat, so i assume that the jet pump oil needs to be checked added or changed depending on what i find since i just bought the boat. How do i go about doing this? i see the little screw on top of the nozzle thing but im not sure how to go about getting to it.

    Thanks!


  2. #2
    JayZ's Avatar
    Join Date
    Feb 2006
    Location
    mississauga, ontario
    Posts
    407
    +1
    1
    easiest way i found was to remove the pump and change the oil on my work bench. you can do it while on the ski, but it does get a bit messy.

    remove nozzles and disconnect vts arm, then remove 4 nuts holding the pump on. pull the pump, then remove the cone.

    if you are hearing squealing noises, you might want to check the condition of the bearings before adding oil and putting everything back together.

    it could also be your drive shaft bearing carrier (if equipped). there is a zerk fitting on it to add grease.

  3. #3
    Master of the Dooniverse
    Join Date
    May 2006
    Location
    Schenectady, Ny
    Posts
    597
    if it's making squeaking noise and this is the XPL i guarantee it's the mid hull bearing for the rear driveshaft under the seat tower. too much water in the rear of the hull, little gets in bearing(s) rust abit and they get hot and die. has happened twice in my HX's life. can hear it quite clearly and performance falls off exactly as you describe.

    you won't normally hear the pump.


    EDIT:

    Just read JayZ's post....my bad parrotting...

  4. #4
    oops i didnt say, this is a 98 GSX Limited .... A friend of mine mentioned the zerk fitting that could require grease, thats worth checking ... where are these bearings?

  5. #5

    Join Date
    Apr 2005
    Location
    Eureka, MO
    Posts
    404
    +1
    1
    Quote Originally Posted by radeon View Post
    oops i didnt say, this is a 98 GSX Limited .... A friend of mine mentioned the zerk fitting that could require grease, thats worth checking ... where are these bearings?

    Bearings in the pump = part # 4 & part # 9

    Grease fitting on PTO - see attached picture.


    Dan (drb)
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Picture 002.jpg 
Views:	44 
Size:	90.9 KB 
ID:	86189   Click image for larger version. 

Name:	partsimage.jpg 
Views:	51 
Size:	93.4 KB 
ID:	86190  

  6. #6
    Quote Originally Posted by drb View Post
    Bearings in the pump = part # 4 & part # 9

    Grease fitting on PTO - see attached picture.


    Dan (drb)
    Correct me if im wrong, but that doesnt look too terribly difficult to put new bearings in?

  7. #7
    Master of the Dooniverse
    Join Date
    May 2006
    Location
    Schenectady, Ny
    Posts
    597
    no, they just need to be banged out or pressed out. OEM tool uses a heavy metal pusher and your own supplied hammer, lol.

  8. #8
    Quote Originally Posted by The Wayniac View Post
    no, they just need to be banged out or pressed out. OEM tool uses a heavy metal pusher and your own supplied hammer, lol.
    i took the jet pump apart today, its all ruined. On the end of the impeller theres that rubber seal, it was kinda bunched up .. can water get in through the splines from that rubber seal where the impeller is?

    I pulled the end cover and it was FULL of water!

  9. #9

    Join Date
    Apr 2005
    Location
    Eureka, MO
    Posts
    404
    +1
    1
    Quote Originally Posted by radeon View Post
    i took the jet pump apart today, its all ruined. On the end of the impeller theres that rubber seal, it was kinda bunched up .. can water get in through the splines from that rubber seal where the impeller is?

    I pulled the end cover and it was FULL of water!

    The pump won't take in water based on a bad seal on the impeller. You had a leak someplace else. Sounds like it's time for a new pump or a pump rebuild.

    Dan (drb)

  10. #10
    Quote Originally Posted by drb View Post
    The pump won't take in water based on a bad seal on the impeller. You had a leak someplace else. Sounds like it's time for a new pump or a pump rebuild.

    Dan (drb)
    it needs a new pump shaft (its busted up a little bit at the nozzle sized) as well as a bearing kit ... if i order the jet rebuild kit and new shaft from SBT, do i need any special tools besides the impeller tool to do the job?

    Thanks

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB - Parts Seadoo 951 DI oil pump drive shaft
    By Sandell in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 05-16-2012, 08:08 AM
  2. 951 carbed oil injection pump ????????????
    By big john in forum 2-Stroke Performance
    Replies: 3
    Last Post: 10-20-2010, 08:11 AM
  3. 2002 951 Di oil pump
    By 2002gtx in forum 2-Stroke Performance
    Replies: 5
    Last Post: 06-13-2009, 04:28 AM
  4. looking for NEW 951 98xpl oil pump
    By abarrassr07 in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 12-09-2008, 05:16 AM
  5. 951 pump oil
    By sdrider in forum 2-Stroke Performance
    Replies: 5
    Last Post: 05-16-2007, 09:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •