Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    waverider's Avatar
    Join Date
    Jun 2005
    Location
    Brandon, MS
    Posts
    193

    Finally broke 70!!!

    Hey guys,

    added an XS I/C on friday and took the RXT out yesterday, it was running like crap, would only hit 6000 rpms, so i put it back on the trailer and checked everything, looked o.k... put it back on the water and still only getting up to 6000 rpms, rode it for about 5 minutes and it finally cleared up and shot up to 8060...found some flat water and turned on the gps....71.0 and 8040 rpms...whoohoo...and on a hot day..previous best was 68.7 and 8100 rpms.

    temp was 100* with high humidity

    still need to fill in the rideplate bolt holes..

    Im guessing the low rpms are due to how hot it was...

    still have not gotton the 42# injectors or a different SC wheel...

    cant wait for it to get cool around here to see what it can do...


  2. #2
    Avion3333's Avatar
    Join Date
    Dec 2007
    Location
    Cayman Islands
    Posts
    686
    congrats man i'm guessing ur nex goal is 80

  3. #3
    www.bluraycomics1.com bluraycomics's Avatar
    Join Date
    Jun 2008
    Location
    SML
    Posts
    219
    Quote Originally Posted by waverider View Post
    Hey guys,

    added an XS I/C on friday and took the RXT out yesterday, it was running like crap, would only hit 6000 rpms, so i put it back on the trailer and checked everything, looked o.k... put it back on the water and still only getting up to 6000 rpms, rode it for about 5 minutes and it finally cleared up and shot up to 8060...found some flat water and turned on the gps....71.0 and 8040 rpms...whoohoo...and on a hot day..previous best was 68.7 and 8100 rpms.

    temp was 100* with high humidity

    still need to fill in the rideplate bolt holes..

    Im guessing the low rpms are due to how hot it was...

    still have not gotton the 42# injectors or a different SC wheel...

    cant wait for it to get cool around here to see what it can do...
    Great success!! Did you do any tweaking or did it just clear up on its own?

  4. #4
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Congrats...

  5. #5
    wolf513's Avatar
    Join Date
    Jun 2008
    Location
    Sacramento, CA
    Posts
    92
    CONGRATS!!!

    I'm still looking to break that magic 70mph mark.

    Yesterday the best I could get before the GPS batteries died was 67.2 (7950rpms)

    1/2 tank, 200lb rider
    Outside temp - 93F at 500ft 28% humidity.
    This yielded a 3000ft density altitude as seen by the engine.

    I guess I need to get an I/C and larger injectors.
    That or I just have to wait for it to cool off a bit and then I should break 70.

  6. #6
    waverider's Avatar
    Join Date
    Jun 2005
    Location
    Brandon, MS
    Posts
    193
    NEXT GOAL IS 75!!!.....I will need alot more than an x-charger and a rrfpr, I think...


    The bogging/missing cleared up on its own, Im guessing with the cooler air from the I/C that the ecu had
    to relearn the fuel curve..

    also i think the prop is holding me back now, its a 14/17r with 2mm added to it...
    I think i screwed it up because i kinked one of the blades...

    I was at 68 at 8150 with the 14/17r then i added 4" rear intake, Jims rideplate with skeggs, GH waterbox, XS I/C, and added 2mm to the pitch and now im at 71 at 8050, but is was alot hotter than earlier in the year...also i was getting some bouncing over 70 on flat water, need to shim the plate..
    Last edited by waverider; 07-29-2008 at 09:11 AM.

  7. #7
    Gus13letter's Avatar
    Join Date
    Apr 2008
    Location
    Tampa Bay, FL
    Posts
    8,136
    +1
    823
    Congrats. Gotta love a fast RXT.

  8. #8
    SHO stopper palmbeach jesse's Avatar
    Join Date
    Nov 2007
    Location
    palm beach fl
    Posts
    3,225
    well, now you have the "speed bug".
    Get ready to cash in the 401K....

  9. #9
    waverider's Avatar
    Join Date
    Jun 2005
    Location
    Brandon, MS
    Posts
    193
    "speed bug"..... already had that, put umteen dollars into a 2001 xlt only to get it to 75....trying not to go overboard on this one like i did on the XLT...but i dont think i can help myself, already looking at the x-charger...






    i also have a 2000 gpr that i have been working on...havent showed anybody here after i got the paint, decals, and mats done....wachta think??


    Last edited by waverider; 07-29-2008 at 03:16 PM.

  10. #10
    Will work on YOUR ski for FREE! GeoRXT's Avatar
    Join Date
    Mar 2006
    Location
    Miami, FL
    Posts
    4,438
    +1
    1
    Oh boy......I remember when I first hit 70+....Get ready to shell out some green ones!....Enjoy!...My suggestion...Rude charger, riva ecu, 50# injectors VTS system and a 15/20 prop....75+ easily....nasty acceleration!

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Finally Broke 70
    By turbojamie in forum 4-Tec Performance
    Replies: 2
    Last Post: 08-18-2008, 10:55 AM
  2. Finally hit 70
    By rwells173 in forum 4-Tec Performance
    Replies: 17
    Last Post: 09-24-2007, 06:32 PM
  3. Finally broke in.
    By Jimbo in forum 4-Tec Performance
    Replies: 18
    Last Post: 07-25-2007, 04:30 PM
  4. Finally broke into the 80's in salt water
    By Hecyan in forum 4-Tec Performance
    Replies: 7
    Last Post: 05-21-2007, 05:50 PM
  5. finally broke 80
    By N8R in forum Yamaha PWC Performance (2-stroke)
    Replies: 17
    Last Post: 01-04-2007, 11:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •