Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,594
    +1
    128

    Do I need a new Riva rear air filter/screen?

    Has anybody had to replace the filter/screen element in their Riva rear air intake? (Mine has at least 100 hours on it) I am trying to figure something out ... I went Riva Stg 3 ECU over the winter but my rpms have been anywhere from 8100 - 8300 max. I am running a trued 15/19R 3 blade and 83mm nozzle and a friend ran my impeller in his ski (similar setup) and pulled 8400 rpm with the same 83mm nozzle. The ski starts good, and runs great at all rpms, but I am only showing 6 - 7 lbs boost on my boost gauge and rpms are low. I have two A kit superchargers, slip on both is around 110 in lbs (double checked multiple times), and I have pressure tested the entire system (tester over the SC inlet) many times and it holds good pressure, no foam or bubbles with soapy water. I have swapped superchargers and it runs the same with either one, no difference.

    Soo, the ski runs the same with either supercharger, the slip is right on both, there are no boost leaks or other funny behavior ... so I am wondering ... my Riva filter element is quite dirty looking and I am now wondering if that might be the culprit? Next time I get out I will remove it entirely and run it, but in the meantime I wondered if anybody else has had noticeable restriction when the screen got old/stained looking? It does not have visible dirt on it of course, but it is definitely stained looking.


  2. #2
    Banned User
    Join Date
    Jul 2006
    Location
    Ft.Lauderdale
    Posts
    3,237
    Quote Originally Posted by Vern View Post
    Has anybody had to replace the filter/screen element in their Riva rear air intake? (Mine has at least 100 hours on it) I am trying to figure something out ... I went Riva Stg 3 ECU over the winter but my rpms have been anywhere from 8100 - 8300 max. I am running a trued 15/19R 3 blade and 83mm nozzle and a friend ran my impeller in his ski (similar setup) and pulled 8400 rpm with the same 83mm nozzle. The ski starts good, and runs great at all rpms, but I am only showing 6 - 7 lbs boost on my boost gauge and rpms are low. I have two A kit superchargers, slip on both is around 110 in lbs (double checked multiple times), and I have pressure tested the entire system (tester over the SC inlet) many times and it holds good pressure, no foam or bubbles with soapy water. I have swapped superchargers and it runs the same with either one, no difference.

    Soo, the ski runs the same with either supercharger, the slip is right on both, there are no boost leaks or other funny behavior ... so I am wondering ... my Riva filter element is quite dirty looking and I am now wondering if that might be the culprit? Next time I get out I will remove it entirely and run it, but in the meantime I wondered if anybody else has had noticeable restriction when the screen got old/stained looking? It does not have visible dirt on it of course, but it is definitely stained looking.
    Vern,

    I was down about 100 RPM's and PBJ kept telling me to get rid of red filter element a run window screen..I decided to clean it.. cleaned with soap and water..100 RPM's came back!!

  3. #3
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,594
    +1
    128
    Thanks Alex, I never thought of cleaning it ... good plan. As stained as mine is and how small the holes are, cleaning it might help me quite a bit.

  4. #4
    Banned User
    Join Date
    Jul 2006
    Location
    Ft.Lauderdale
    Posts
    3,237
    After I cleaned it, I checked to see if I screwed the water restricting properties of the element and it did not!!

  5. #5

    Join Date
    Aug 2006
    Location
    Louisville,Tn
    Posts
    140
    vern,when I installed my riva rear air I was always seeing 50rpm better without the filter than with it installed.filter was new and clean as well

  6. #6

    filter

    i dont run one either and saw more rpm's with holes in the gra rail .....no florites

  7. #7
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    hmm, i think i may go take a look at my filter. I got 2 extra ones, but i see some like it with nothing.

    I run nothing on my Jawz air intake and can tell a big difference without any restriction so might be better on rear air also.

  8. #8
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Vern, after you posted this i thought i would change mine out. Not sure how old mine is as i bought the setup used and havnt ever changed it. I bet it was used for atleast one season or more.
    I blew off the dirt that was on there but look at the discolor from the old to new one. sounds like it looks like yours.
    Probably not a big deal but all the little details can add up.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_1634.jpg 
Views:	45 
Size:	189.4 KB 
ID:	85744   Click image for larger version. 

Name:	IMG_1637.jpg 
Views:	35 
Size:	159.6 KB 
ID:	85745  
    Last edited by skoepp; 07-30-2008 at 12:59 AM.

  9. #9
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,594
    +1
    128
    My filter looks even worse than that ... I am hoping to get out to the cottage and run it without the filter this Saturday.

  10. #10
    Banned User
    Join Date
    Jul 2006
    Location
    Ft.Lauderdale
    Posts
    3,237
    I thought about taking mine off to but I always pull all kind of crap off that element..Without it all that chit is getting trapped in your IC coils..

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS: Brand New RXP Riva Rear Air Intake Kit
    By Kohl531 in forum Sea Doo Classifieds
    Replies: 7
    Last Post: 03-16-2012, 07:30 PM
  2. FS Riva rear air filter
    By h2jim in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 08-11-2011, 11:55 PM
  3. FS Riva rear air filter And RXP drive shatf
    By Rompe21 in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 10-25-2010, 05:48 AM
  4. FS Riva REAR AIR RXP Brand New
    By Treemn in forum Sea Doo Classifieds
    Replies: 18
    Last Post: 09-24-2009, 03:06 PM
  5. New riva rear air intake!!
    By Turbo Nick in forum 4-Tec Performance
    Replies: 19
    Last Post: 09-29-2007, 03:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •