Results 1 to 5 of 5
  1. #1
    Prohibido usuario
    Join Date
    Aug 2005
    Location
    Jerry's guest bedroom
    Posts
    3,469
    +1
    2

    Mods I completed today

    I just love looking at peoples pics of mods. Nothing fancy today. Replaced damaged impeller and wear ring. Good news dealer charged me $51.50 for ring without me even having to cry for a discount. He also changed impellers for free, just took him the housing with tail cone removed. Picked up glove box and storage bin finally, been waiting forever. Locked opas in the up position and removed the hose that supplied water pressure from pump. I put a block off in the steering nozzle hole and filled it with epoxy so its smooth. I also filled the ride plate holes. I am going to go back and trim the silicone on the grate after it cures with a razor blade. I also modified my nose cone by trimming it down. Check out the cool locktite kit I got from my neighbor.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	bad impeller.jpg 
Views:	46 
Size:	1.05 MB 
ID:	4787   Click image for larger version. 

Name:	both impellers.jpg 
Views:	60 
Size:	1.30 MB 
ID:	4788   Click image for larger version. 

Name:	damage.jpg 
Views:	57 
Size:	1.44 MB 
ID:	4789   Click image for larger version. 

Name:	nose cone mod.jpg 
Views:	51 
Size:	1,015.4 KB 
ID:	4790   Click image for larger version. 

Name:	opas riser.jpg 
Views:	53 
Size:	1.05 MB 
ID:	4791   Click image for larger version. 

Name:	opas line block off.jpg 
Views:	53 
Size:	1.17 MB 
ID:	4792  

    Click image for larger version. 

Name:	pump block off.jpg 
Views:	53 
Size:	1.16 MB 
ID:	4793   Click image for larger version. 

Name:	inside pump.jpg 
Views:	52 
Size:	1,006.2 KB 
ID:	4794   Click image for larger version. 

Name:	gps.jpg 
Views:	52 
Size:	1.08 MB 
ID:	4795   Click image for larger version. 

Name:	bucket.jpg 
Views:	49 
Size:	1.31 MB 
ID:	4796   Click image for larger version. 

Name:	ride plate holes filled.jpg 
Views:	72 
Size:	1.20 MB 
ID:	4797   Click image for larger version. 

Name:	locktite.jpg 
Views:	53 
Size:	1.40 MB 
ID:	4798  

    Last edited by NCHeel; 07-25-2006 at 04:11 PM.


  2. #2
    WOW that prop got banged up!
    Don`t forget to unstick water reducer disc from pump and place back into pump support before re-installing pump!

    Also, you can take that hose off and just get a rubber cap with a small clamp will do the job nicely...

    Well another one has the mod bug!...PR...

  3. #3
    Prohibido usuario
    Join Date
    Aug 2005
    Location
    Jerry's guest bedroom
    Posts
    3,469
    +1
    2
    Are you refering to the yellow thing in the one pic? I've always left it on the pump housing. I tugged on it slightly (the reason it has black suet on it) it felt secure so I didn't want to break it by tugging it off. Why not install it like it is? Yeah i looked for a cap but couldn't find one so I rigged that setup.

  4. #4
    Prohibido usuario
    Join Date
    Aug 2005
    Location
    Jerry's guest bedroom
    Posts
    3,469
    +1
    2
    Someone, whats the deal about the water reducer?

  5. #5
    Yes, the yellow disc is the water reducer disc, and gently remove it and place it into the slots where it belongs, this way there is no chance of pinching the seal or have the pump housing leak water for that port!...PR...

    somewhere here is alot of info on it, do a search on Water reducer disc and see what shows up!...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FFP Raider mod pipe / complete
    By blaster800 in forum Yamaha Classifieds
    Replies: 3
    Last Post: 07-08-2009, 06:00 PM
  2. First Ride On Modded Gtx Sc Today.
    By carl sagan in forum 4-Tec Performance
    Replies: 12
    Last Post: 06-26-2007, 05:49 PM
  3. Speed results-02 xlt triple pipe testing completed today
    By Dirty Sanchez in forum Yamaha Open Discussion
    Replies: 4
    Last Post: 01-06-2007, 07:27 PM
  4. did the water box mod today
    By flyn ryan in forum 4-Tec Performance
    Replies: 0
    Last Post: 03-26-2006, 10:12 PM
  5. Got my first mods in the mail today!
    By 05RXPnoob in forum 4-Tec Performance
    Replies: 1
    Last Post: 07-30-2005, 06:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •