Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1

    Join Date
    May 2008
    Location
    South Eastern Michigan
    Posts
    198

    RXP-X HUGE JUMP, now hesitation after hard landings. Any Ideas (Please)?

    Hey Everyone,

    Installed some new mods on the ski last week. Took a few days off of work and skied from Wed. through the weekend.

    On Saturday hit a HUGE jump and landed on top of another wave (smacked the wave) and experienced some hesitation (no power, running on various cylinders) for a couple seconds and then it returns back to normal running. I experienced this prob. 5 or six times for the rest of the weekend, each time after landing large jumps hard.

    Something has got to be loose is my opinion, but looking for suggestions as to what? All I installed last week was the Solas and the Riva "Free-flow" exhaust pipe. The only think I disconnected was the VTS which is working fine. The other mods were installed 3 weeks ago and have ~14 hours of riding on them (26 hours on the ski total).

    Could not having the 20+ zip ties that I removed in the process of installing stuff have caused some wire to work it's way out or something? I was thinking along the lines of the dash wires, or the moved ignition box thingy (from installing the intake)?

    -=Mike :help
    Last edited by Mikey G.; 07-29-2008 at 12:15 PM.


  2. #2
    Banned User
    Join Date
    Jul 2006
    Location
    Ft.Lauderdale
    Posts
    3,237
    That happens to me when I ride surf, I think it has something to do with the rear exhaust

  3. #3
    subparwelder's Avatar
    Join Date
    Jun 2008
    Location
    park hills, MO
    Posts
    100
    I have the same problem with mine. All I jump are lake wakes and my bike has done this since I got it.

  4. #4
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    It could have been the mercury switch for the TOPS kicking in... Ron

  5. #5
    mine too,maybe its normal due to the high attiude of the ski in the jump

  6. #6

    Join Date
    May 2008
    Location
    South Eastern Michigan
    Posts
    198
    Quote Originally Posted by King_Of_Fun View Post
    It could have been the mercury switch for the TOPS kicking in... Ron
    Wow... I wasn't aware there was such a thing? What is TOPS exactly? (I'm going to search now).

    This weekend was the first time I noticed this happening, however these jumps were definitly the most extreme (and hardest landing) I have done yet. Scared the crap outta me a couple of times. These are boat wakes in lakes I'm talking about, and it seemed to start after I FLEW and landed on top of another TALL/SHARP wake "smacking" it down.

    I'm getting more and more comfortable with this thing.

    So, this may be semi-normal? I'm going to re-check connections and such, but I have a feeling that the issue would have to be worse than it is to warrant taking it to a dealer for warranty work. Most jumps (even big ones) are fine, it just depends on how hard the landing is.

    -=Mike G.

  7. #7
    Moderator Franko's Avatar
    Join Date
    Apr 2005
    Location
    Dallas, Texas
    Posts
    3,829
    +1
    2
    Quote Originally Posted by King_Of_Fun View Post
    It could have been the mercury switch for the TOPS kicking in... Ron
    Yep.

  8. #8
    Gotta love this sport! 05Limited's Avatar
    Join Date
    Apr 2005
    Location
    Stockton, CA
    Posts
    2,677
    +1
    4
    Tip over protection system... TOPS.

    Also, check for low oil. If you slosh oil during jumps or high G turns, and it's on the low side, sensors will cause the ski to limp.

  9. #9

    Join Date
    May 2008
    Location
    South Eastern Michigan
    Posts
    198
    Yep... thought of the low oil thing. It's actually over-filled a bit IMHO (dealer 10hr service was the latest oil change). When cold it's just over the top line/bend. I didn't check it when hot though... it's probably WAY over the top line when hot then. I could be loosing power, but my RPMs seem good. I'll pump some out for kicks and see what happens.

    -=Mike G.

  10. #10
    rx4pain's Avatar
    Join Date
    Apr 2005
    Location
    Olympia, WA
    Posts
    1,965
    +1
    2
    Definitely TOPS...mine does that occasionally on bigger lake waves. I just feather the throttle until she starts to breath again.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1998 XL 1200 runs great and then DIES after carb rebuild - any ideas?
    By GreenAdam in forum Yamaha Old School Skis
    Replies: 7
    Last Post: 07-13-2016, 11:56 AM
  2. Virage 700 bad running after hard landing
    By darrel in forum Polaris Open Discussion
    Replies: 11
    Last Post: 09-04-2007, 12:13 PM
  3. 1996 polaris slt 780 intermitant hesitation and low power,any ideas?
    By Fraser327 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 08-02-2007, 06:10 PM
  4. 2003 XP DI or 2005 RXP for wave jumping
    By krummel21 in forum Sea Doo Open Discussion
    Replies: 49
    Last Post: 03-08-2007, 12:46 AM
  5. it wont start (after hard landing)
    By rxpkid229 in forum Sea Doo Open Discussion
    Replies: 40
    Last Post: 06-12-2006, 11:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •