Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 25

Thread: Coolant??

  1. #1
    bavboym3's Avatar
    Join Date
    Mar 2008
    Location
    Pittsburgh, PA
    Posts
    234
    +1
    6

    Coolant??

    I rode my jet ski down in Deep creek maryland this weekend. Somehow it overheated?? It went into a mode and started beeping. I turned it off, floated to safety. The coolant tank was empty!!! I had no choice but to add some lake water to it after it cooled down. I made it back to my dock. Filled it with green coolant, rode it for 15mins.. Came back to the dock, and it was below the low line maybe an inch. I was thinking it just needed that much to go through the system..

    I put the ski on a trailor, and brought it back to Pittsburgh.. Now I am going to flush the colant system...

    Questions..

    1. Do I need to add water to the coolant, or just straight green coolant?

    2. Has anyone had this happen before?

    3. Should I be worried?


  2. #2

    Join Date
    Jan 2007
    Location
    Las Vegas, NV
    Posts
    325
    Quote Originally Posted by bavboym3 View Post
    I rode my jet ski down in Deep creek maryland this weekend. Somehow it overheated?? It went into a mode and started beeping. I turned it off, floated to safety. The coolant tank was empty!!! I had no choice but to add some lake water to it after it cooled down. I made it back to my dock. Filled it with green coolant, rode it for 15mins.. Came back to the dock, and it was below the low line maybe an inch. I was thinking it just needed that much to go through the system..

    I put the ski on a trailor, and brought it back to Pittsburgh.. Now I am going to flush the colant system...

    Questions..

    1. Do I need to add water to the coolant, or just straight green coolant?

    2. Has anyone had this happen before?

    3. Should I be worried?
    I would check to see if it is leaking and if it is fix that first. Rule of thimb with all coolants is 50% coolant and 50% water.

  3. #3
    bavboym3's Avatar
    Join Date
    Mar 2008
    Location
    Pittsburgh, PA
    Posts
    234
    +1
    6
    Quote Originally Posted by Mac View Post
    I would check to see if it is leaking and if it is fix that first. Rule of thimb with all coolants is 50% coolant and 50% water.
    How do I check for leaks?

    If im not mistaken it says Coolant only on the RXP bottle... The sea doo dealer told me to dump the coolant straight in.. Maybe it was premixed?

  4. #4
    bavboym3's Avatar
    Join Date
    Mar 2008
    Location
    Pittsburgh, PA
    Posts
    234
    +1
    6
    How much coolant does it hold? I guess I will do 50/50 with distilled water

  5. #5

    Join Date
    Jan 2007
    Location
    Las Vegas, NV
    Posts
    325
    Put the ski on the trailer and walk around it, do you see any green fluid underneath the ski? Check the ride plate if not lift the seat and start checking in the motor compartment. If you cannot find anything pressurize the lines, any leaks there. Try checking the dip stick see if the oil is green or foamy you may have a blown head gasket.

    As fo rthe coolant I have always mixed 50/50 and have never had any trouble. I was told if you run 100% coolant it will not disapate heat effectively.

  6. #6

    Join Date
    Jan 2007
    Location
    Las Vegas, NV
    Posts
    325
    Quote Originally Posted by bavboym3 View Post
    How much coolant does it hold? I guess I will do 50/50 with distilled water
    Water out of the hose works too and it is cheaper.

  7. #7
    bavboym3's Avatar
    Join Date
    Mar 2008
    Location
    Pittsburgh, PA
    Posts
    234
    +1
    6
    Quote Originally Posted by Mac View Post
    Water out of the hose works too and it is cheaper.
    Think it will hurt anything?

    So I should just look for spills under the trailor..
    Check the compartment for any coolant..
    Drain it.. Fill it 50/50
    Ride it and see what happens...

  8. #8
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    And check in the hull. The plastic pvc nipples that connect to the ride plate have a history of leaking antifreeze into the hull due to the clamps. Like another post said, check the oil for foam.

  9. #9
    bavboym3's Avatar
    Join Date
    Mar 2008
    Location
    Pittsburgh, PA
    Posts
    234
    +1
    6
    Quote Originally Posted by King_Of_Fun View Post
    And check in the hull. The plastic pvc nipples that connect to the ride plate have a history of leaking antifreeze into the hull due to the clamps. Like another post said, check the oil for foam.
    Can I chck it when its cold? Just pull the dipstick, and look for color/foam?

    I heard its very hard to see those clips on the ride plate on the X model.. Because the intercooler is so big

  10. #10
    bavboym3's Avatar
    Join Date
    Mar 2008
    Location
    Pittsburgh, PA
    Posts
    234
    +1
    6
    my dad told me to fill it up, and start it in the garage.. He said you will smell the colant in the exhaust if there is a head gasket leak?

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How-To: Coolant Change
    By MikeTrin in forum Sea Doo How To & FAQs
    Replies: 65
    Last Post: 07-24-2012, 11:16 AM
  2. 40/60 mix of coolant?
    By Griff350 in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-17-2005, 10:40 AM
  3. Coolant additive = 20 degrees cooler
    By Kinchyle in forum 4-Tec Performance
    Replies: 10
    Last Post: 07-25-2005, 02:51 PM
  4. 2 questions (coolant tube and bailer tubes)
    By mickey78 in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 07-21-2005, 01:22 PM
  5. coolant additive
    By CRAZEDRXP in forum 4-Tec Performance
    Replies: 10
    Last Post: 05-29-2005, 06:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •