Results 1 to 4 of 4
  1. #1
    born riding's Avatar
    Join Date
    Mar 2007
    Location
    richmond, va
    Posts
    294
    +1
    3

    RPM bouncing at max speed

    i did a search and did not find any results, so i will post my observations:
    while riding at wot my ski will lose 100-500 rpms then bounce back to normal. but to me it feels like the ski is running slow and will pull forward with adding 100-500 rpms (to acheive normal top end rpm) then drop back down, almost like it is trying to break loose and let out the power but can't. does this make any sense? has anyone else had similar issues. i did just replace the plugs and will change again to be sure that is not problem. but i have already checked all hoses and bolts, all are tight. waddu ya think?


  2. #2
    ercBOOSTED's Avatar
    Join Date
    Apr 2007
    Location
    Pittsburgh, Pa
    Posts
    1,093
    +1
    3
    Check your hoses on your intercooler first to make sure they are tight. If they are, you may want to replace your gaskets. I have had both happen.

  3. #3
    benjahw benjahw's Avatar
    Join Date
    Jan 2008
    Location
    Naples, Fl
    Posts
    467
    +1
    30
    check your belt tension. ALSO my ski does that when i forget the drain plugs, i let the water out and its back to normal.

  4. #4
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    Quote Originally Posted by born riding View Post
    i did a search and did not find any results, so i will post my observations:
    while riding at wot my ski will lose 100-500 rpms then bounce back to normal. but to me it feels like the ski is running slow and will pull forward with adding 100-500 rpms (to acheive normal top end rpm) then drop back down, almost like it is trying to break loose and let out the power but can't. does this make any sense? has anyone else had similar issues. i did just replace the plugs and will change again to be sure that is not problem. but i have already checked all hoses and bolts, all are tight. waddu ya think?
    sounds to me that your bov may be leaking it is opening then it closes again creating the boosted pressure (block it off and see what happens)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2012 FZS bouncing at high speed
    By Vincent in forum Yamaha PWC Performance (4-stroke)
    Replies: 10
    Last Post: 07-06-2012, 09:48 PM
  2. 2003 F12X cutting out at max speed
    By pwcgwynedd in forum Honda Performance
    Replies: 6
    Last Post: 06-11-2012, 09:09 AM
  3. Stock VXS bounce at top speed... Is bucking next?
    By jayp0209 in forum Yamaha PWC Performance (4-stroke)
    Replies: 21
    Last Post: 06-07-2012, 10:05 PM
  4. F-12x bounces alot at high speeds...?
    By eze in forum Honda Performance
    Replies: 17
    Last Post: 06-21-2010, 07:59 AM
  5. 96 SLT 750 Pulsing at top speed but not full RPM
    By fasman in forum Polaris Open Discussion
    Replies: 13
    Last Post: 07-20-2009, 10:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •