Results 1 to 6 of 6

Thread: Need Help

  1. #1

    Need Help

    I have a 2007 rxp with 7 hrs on it. Water temp 77 outside temp 90. I have changed the washers and bearings. Added a r&d intake grate, a riva power filter, and a prop with low end torque. I am only getting 7360-7400 rpms and 64 mph. When it gets there it almost like its got a govern will not go anymore. My elevation is 5000 ft. Please help me? Would a prop with top end be better? Water is fairly smooth.

  2. #2
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    west texas
    I got plenty of riding at elevation. Let me help you.
    For starters do you know what your rpm were at that elevation bone stock?
    Second, what prop do you have?

  3. #3
    They were 7300-7360 I am not sure the prop I had it sent in and shaved for thrust. It is stock prop I am sure. But My friend got his prop shaved for top speed. So I was thinking of ordering a vts a 2 degree wedge, and maybe a solas 14/19 or would you go with a 15/20. Thanks for the help

  4. #4
    He is running 7700-7780 rpms and 68-69 mph he has added a power filter nothing else. But when we were both stock I could outrun him by 3-3.5 lengths know he is beating me by 4-5 lengths he is about 60lbs heavier also

  5. #5
    The ski's have taken a "backseat" to the Corvette DarthAWM's Avatar
    Join Date
    Nov 2007
    Odessa, TX
    Sounds like a major boost leak to me, I expirenced a sudden loss of RPM do to the hose from the SC to the Intake poppong off, the ski would not rev pas 7200 RPMs when this happened.

  6. #6
    I checked all my hoses they are tight. Is there anything else I can check. Thank you for reminding me to check the sc hose.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. new 05 RXT NEED HELP
    By RXPNJ in forum 4-Tec Performance
    Replies: 12
    Last Post: 07-03-2009, 12:16 PM
    By macattack in forum 4-Tec Performance
    Replies: 28
    Last Post: 11-22-2005, 02:39 PM
  3. My 2 RXP's need HELP!
    By Tube Master in forum 4-Tec Performance
    Replies: 21
    Last Post: 07-19-2005, 09:44 PM
  4. I need help remove stock intercooler
    By orc in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-13-2005, 04:08 PM
  5. NEED HELP!!!!!
    By MartyRXP in forum 4-Tec Performance
    Replies: 11
    Last Post: 05-10-2005, 08:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts