Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    no engine elbchecker's Avatar
    Join Date
    Nov 2007
    Location
    Toulouse, France
    Posts
    129

    RXP very loud Explosion

    Today i want pic up my modified RXP from the dealer. He installed the upgraded Flywheel Bolts, new Pistons and Connecting Rods from Rotax Racing and some other parts.

    At the first 3 Starts nothing happend, on the next Start it gives a very loud Explosion
    The oil runs out of the motor, in under 5 minutes. The leak test, after, was okay and spark pluks too.

    What you guys think, where i can find the oil leak and what can be damaged too.
    THANKS FOR YOUR HELP and sorry for my bad English!


  2. #2
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    My guess would be the plastic intake manifold, but oil shouldn't leak out of it... Ron

  3. #3
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    probably some standing fuel in the intake manifold from when they changed injectors. The fuel ignited and caused the explosion.

    can you tell where the oil is leaking from?

  4. #4
    no engine elbchecker's Avatar
    Join Date
    Nov 2007
    Location
    Toulouse, France
    Posts
    129
    No, not at the moment. They check it tomorrow. But it must be a big leak, because the Engine was dry after 5 minutes.

  5. #5
    no engine elbchecker's Avatar
    Join Date
    Nov 2007
    Location
    Toulouse, France
    Posts
    129
    We cant see it.
    So i think it must be on the bottom.

  6. #6
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    If it's the bottom, it's bad. Can you post a picture?... Ron

  7. #7
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Hopefuly you have 2 different probs and the explosion was not related to the oil leak.

  8. #8
    no engine elbchecker's Avatar
    Join Date
    Nov 2007
    Location
    Toulouse, France
    Posts
    129
    Today, they start working on it. When i know more, i will post it.
    I hope, its not so bad..............

  9. #9
    no engine elbchecker's Avatar
    Join Date
    Nov 2007
    Location
    Toulouse, France
    Posts
    129
    Not so bad A plug screw break out. In the picture, its number 10-11.
    http://partsfinder.onlinemicrofiche....8&B=4&Action=O
    Last edited by elbchecker; 08-05-2008 at 11:32 AM.

  10. #10
    RXPDAVID's Avatar
    Join Date
    Apr 2005
    Location
    West Tennessee
    Posts
    403
    It looks to me that they did not set the cam timming correct.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Waverunner FZR (Stage 3) very loud vibrations at fullthrottle
    By Oberststubinski in forum Yamaha PWC Performance (4-stroke)
    Replies: 17
    Last Post: 07-30-2011, 04:52 PM
  2. FS Jims ride plate for RXP very clean.
    By caliburst in forum Sea Doo Classifieds
    Replies: 7
    Last Post: 09-20-2009, 09:39 PM
  3. temp warning beep... very loud.
    By C DOO 88 in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-26-2009, 09:04 PM
  4. Stock SC very loud. What gives?
    By 01xdime in forum 4-Tec Performance
    Replies: 15
    Last Post: 10-13-2008, 11:43 PM
  5. 07 RXP very catastrophic ceramic failure at 5 hours
    By Green Hulk in forum 4-Tec Performance
    Replies: 92
    Last Post: 04-06-2007, 01:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •