Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1
    Kroth Rocket
    Join Date
    Jul 2008
    Location
    Pittsburgh, PA
    Posts
    43

    Ski shutting off! HELP!!!

    Today out on the water, my ski shut off 3 times. 2 of the times I can speficially remember it shutting off after jumping a small wake. After landing, it would almost be like I pulled my landyard out- the ski would still be on but when I hit the throttle, nothing would happen. I would hit my start button and the ski would start up with problem. Any idea what would be causing this?

    I just changed my oil, but I doubt that would have any direct effect.

    Any help would be appreciated!


  2. #2
    Two of my best guesses :-

    1) Loose connection on the battery, not sure whether this would stop ski.
    2) Tip over sensor faulty, loose or dodgy connection. I have known my ski to stop when I have come down hard at an angle.

  3. #3
    Battery connections would cause it. After riding out in the ocean my battery straps came loose, which in turn finally worked my connections loose. Sometimes I would hit a wake and it would just die. Then crank right back up like there was no problem. Tightened battery back up and no problems since.

    Jason

  4. #4
    my ultra 150 also done this and it turned out to be the plug caps were not screwed on the the leads properly

  5. #5
    Kroth Rocket
    Join Date
    Jul 2008
    Location
    Pittsburgh, PA
    Posts
    43
    Thanks guys for the help. I planned on changing my spark plugs anyways, so if that was the problem, that should take care of it.

    I will also check my battery connection while I'm in there.

    Thanks again!

  6. #6
    pete71's Avatar
    Join Date
    Apr 2007
    Location
    AUSTRALIA(Melb)
    Posts
    685
    +1
    21
    mike, does any error code come up on the dash ?

  7. #7
    Rehab'ed Ron sixtydashone's Avatar
    Join Date
    Jun 2008
    Location
    Toms River
    Posts
    1,026
    i have an 08 15f, and i went wave jumping yesterday, and mine did the same thing

    i will have to check the battery cable as well.. it must have shut off at least 6-7 times after big waves

  8. #8
    Kroth Rocket
    Join Date
    Jul 2008
    Location
    Pittsburgh, PA
    Posts
    43
    Quote Originally Posted by pete71 View Post
    mike, does any error code come up on the dash ?

    Nope, no error code. It just shuts off like the landyard was pulled off (but it wasn't- i thought that the first time, but then it happened twice more)

  9. #9
    Kroth Rocket
    Join Date
    Jul 2008
    Location
    Pittsburgh, PA
    Posts
    43
    I know you all were eagerly anticipating the result of this problem so.... when I checked my batterty connection, one was very loose. This could be the reason I was losing power after being in the air.

    Also, I'm not sure if you guys changed your spark plugs yet, but I did yesterday and I noticed a LOT of a yellow petroleum jelly looking substance inside. I know some is needed for lubrication, but I mean it was caked on! Look for this when changing plugs.

  10. #10
    inchadeboca's Avatar
    Join Date
    Oct 2007
    Location
    miami
    Posts
    555
    +1
    2
    Quote Originally Posted by Mike 15Fer View Post
    I know you all were eagerly anticipating the result of this problem so.... when I checked my batterty connection, one was very loose. This could be the reason I was losing power after being in the air.

    Also, I'm not sure if you guys changed your spark plugs yet, but I did yesterday and I noticed a LOT of a yellow petroleum jelly looking substance inside. I know some is needed for lubrication, but I mean it was caked on! Look for this when changing plugs.
    ...petroleum jelly ? didnt notice any on my spark plugs at least

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 Yamaha FX HO stalls over half throttle. Computer says "LO" &Ski Shuts off. Help?
    By evankayeotis in forum Yamaha PWC Performance (4-stroke)
    Replies: 13
    Last Post: 07-06-2016, 08:21 AM
  2. 2004 Yamaha xlt800 won't shut off HELP
    By ohiocop in forum Open Discussion
    Replies: 0
    Last Post: 04-03-2015, 12:30 PM
  3. Wot ski shuts off 08rxpx
    By Palm Beach Punisher in forum 4-Tec Performance
    Replies: 10
    Last Post: 10-20-2012, 03:55 PM
  4. Ski shutting off when not on throttle
    By Sea-Yaa in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-07-2009, 03:12 PM
  5. 94 750 SL would not shut off!!! HELP!!!
    By ashelgren in forum Polaris Open Discussion
    Replies: 11
    Last Post: 09-01-2008, 09:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •