Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1
    giguchan's Avatar
    Join Date
    Sep 2007
    Location
    LI I$land New york
    Posts
    1,683
    +1
    24

    Question during Free Flow Exhaust mod.. remove water box?

    Hey all,
    I'm wondering.. While doing the FFE Mod.. did any remove the Left hand side Water box.. to make the connections to the Exhaust? then re install it? I'm havin a helluva time getting the exhaust connected.. any tips or tricks?it seems like a lot of work to remove it.
    Thanks..


  2. #2
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,166
    +1
    602
    Quote Originally Posted by giguchan View Post
    Hey all,
    I'm wondering.. While doing the FFE Mod.. did any remove the Left hand side Water box.. to make the connections to the Exhaust? then re install it? I'm havin a helluva time getting the exhaust connected.. any tips or tricks?it seems like a lot of work to remove it.
    Thanks..
    No primary stay's put!!!!
    where u having dramas, its only 2 rubber U pipes use some lube, or even use hot water to soften elbow, then bit of lube spray, bingo its on.

    It is just the U pipie u doin yer??

    got pics of your trouble pipe.

    Waz

    I have had mine out heaps of times with no probs, U puttin the correct hose on correct pipe.

  3. #3
    giguchan's Avatar
    Join Date
    Sep 2007
    Location
    LI I$land New york
    Posts
    1,683
    +1
    24
    hey,
    I'm just at the last part of the install.. I have the billet installed to the rear, so now all i have to do is make the 2 connections- at the water box and at the exhaust tube. The only reason i mentioned removing the Box is because One of the watercraft Mag's suggested that if you spend more than one hour trying to make the connections just yank the box make the connection and the re install the box.It seems like a lotta work though.. I was hoping to do this without doing that..

  4. #4
    giguchan's Avatar
    Join Date
    Sep 2007
    Location
    LI I$land New york
    Posts
    1,683
    +1
    24
    Thanks for the link.
    I've been there many times.... if i cannot get every thing to link properly.. i'm going to look into a flexible type of hose since there was one originally i dont see why i cannot use another one.. Thanks.

  5. #5
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,166
    +1
    602
    Quote Originally Posted by giguchan View Post
    Thanks for the link.
    I've been there many times.... if i cannot get every thing to link properly.. i'm going to look into a flexible type of hose since there was one originally i dont see why i cannot use another one.. Thanks.

    that should b fine, were are u have the drama exactly tho

    you can always mod things.

    but these have fitted with no real trouble , just need patience

    Waz

    pic would help my brain see your prob

  6. #6
    giguchan's Avatar
    Join Date
    Sep 2007
    Location
    LI I$land New york
    Posts
    1,683
    +1
    24
    the drama is just getting everything lined up properly.. and following the directions It seems that after they advise you of what to do I always find a better way of doing it. except this time..I think i might have to try a flexible hose.. Yes a Mod for the Mod

  7. #7

    Join Date
    Apr 2008
    Location
    Alabaster, Alabama
    Posts
    66
    I installed mine a couple weeks ago, before I bolted the billet tip to the ski I went ahead and made the connection outside the hull on the exhuaust outlet and then I had to work the water box connection on. It took me about 3 hours total because I was getting frustrated and had to walk away a couple of times.

  8. #8
    giguchan's Avatar
    Join Date
    Sep 2007
    Location
    LI I$land New york
    Posts
    1,683
    +1
    24
    Hey thanks for the reply..
    So if i'm getting you right.. you made the connection to the exhaust tube out side of the hull? meaning that you took the riva piece pushed it thru the hole in the hull?That sounds like a great idea... i'll try that tomorow.
    When i installed the power filter i walked away alot...(i still say that the performance tube is too close to the fuel tank sending unit)
    So after that then you pushed back thru the hull and then made the connection on the waterbox?
    Thanks for this approach...

  9. #9
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    Quote Originally Posted by giguchan View Post
    hey,
    I'm just at the last part of the install.. I have the billet installed to the rear, so now all i have to do is make the 2 connections- at the water box and at the exhaust tube. The only reason i mentioned removing the Box is because One of the watercraft Mag's suggested that if you spend more than one hour trying to make the connections just yank the box make the connection and the re install the box.It seems like a lotta work though.. I was hoping to do this without doing that..
    ive read the same mag pretty easy to follow there instructions and recommendations the pictures explained alot also and yes it did say remove the water box if you have trouble thats what i would do.

  10. #10

    Join Date
    Apr 2008
    Location
    Alabaster, Alabama
    Posts
    66
    That would be correct, leave the connection at tht outlet a little loose and work the clamps in thru the hull, line the other end up with the waterbox outlet with out the coupling. Make sure that the billet outlets bolts holes are lining up right, tweak if needed (that is why u leave it a little loose). Gently remove it out thru the hull in order to tighten the clamps at the outlet securely now. Slide on the coupler to the water box outlet, slide the exhaust assembly back in the hull and make the connection and the water box.


    Hope this helps some, you will definately like the sound of it.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. XL1200 ltd free flow exhaust worth it ?? Also looking for reliability mod ideas.
    By chevydog in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 06-02-2015, 09:21 PM
  2. Free Flow Exhaust Mod Questions
    By 07STX15 in forum Kawasaki How To & FAQs
    Replies: 2
    Last Post: 04-03-2011, 11:49 PM
  3. Make your own free flow exhaust mod?
    By TX21 in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 07-27-2010, 07:38 PM
  4. will the fx free flow exhaust mod fit the vx
    By nev350 in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 07-08-2007, 05:43 PM
  5. PPG Free Flow Exhaust
    By RXP19 in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-14-2005, 10:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •