Results 1 to 10 of 10
  1. #1

    Should I have used this oil, got more rpms.......

    I have been having a problem with rpms and speed for some time now but the ski runs fine so I havent messed with it. I was out at the lake and as soon as I left the dock the low oil light comes on and it goes into limp mode. I send my buddy to get oil at the marina and he comes back with 1 quart of quicksilver 25w-40, is this a good oil to use. I have never heard anybody here use that before, but I said ok what choice do I have so I put the whole quart in and it went from not reading on the dipstick to reading almost at the top for some reason. I take it out on the water and I finally get 7000 rpms after weeks of 6750 to 6800, but only for a little while. I ride for 20 minutes and it is good at 7000 but then when I go back to our campsite and go back out it is the same old bs at 6750. Is this oil ok to use and wtf is going on with this machine, it is seriously weird. By the way it is the 03 seadoo obviously.


  2. #2

    Join Date
    Sep 2007
    Location
    Myrtle Beach, SC
    Posts
    83
    Maybe the thicker oil temporarily caused the SC clutch to not slip as much as usual so you got more boost= more rpms. ?

  3. #3
    Excactly what I was thinking, is it ok to run that thick of an oil?

  4. #4
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Me personaly..I wouldnt.

  5. #5
    Masterz's Avatar
    Join Date
    Jun 2008
    Location
    Watson, LA
    Posts
    219
    +1
    1
    I wouldnt run it either... I would pull the charger and make sure it isnt slipping. Might be time for a rebuild.

  6. #6

    Join Date
    Jun 2006
    Location
    Richmond, Va
    Posts
    240
    Sounds like time for a rebuild. Even the 7K you saw with the thickner oil is still low so something is wrong.

  7. #7
    800AMSOIL4U's Avatar
    Join Date
    Aug 2006
    Location
    Morgan Hill, CA
    Posts
    5,024
    +1
    132
    Quote Originally Posted by super_gtx View Post
    I have been having a problem with rpms and speed for some time now but the ski runs fine so I havent messed with it. I was out at the lake and as soon as I left the dock the low oil light comes on and it goes into limp mode. I send my buddy to get oil at the marina and he comes back with 1 quart of quicksilver 25w-40, is this a good oil to use. I have never heard anybody here use that before, but I said ok what choice do I have so I put the whole quart in and it went from not reading on the dipstick to reading almost at the top for some reason. I take it out on the water and I finally get 7000 rpms after weeks of 6750 to 6800, but only for a little while. I ride for 20 minutes and it is good at 7000 but then when I go back to our campsite and go back out it is the same old bs at 6750. Is this oil ok to use and wtf is going on with this machine, it is seriously weird. By the way it is the 03 seadoo obviously.

    That oil may have friction modifiers in it, since it is for marine applications and potentially have supercharger clutch slipage issues. If you are low you can normally run a JASO MA motorcycle oil that is safe for wet clutches.

  8. #8
    The supercharger intake will not spin, I took it off and I tried to spin it and nothing.

  9. #9
    Jeepster's Avatar
    Join Date
    Jul 2007
    Location
    Quebec, Canada
    Posts
    754
    Remove that oil anyway....25W40 is very much too thick, the correct grade should be 10W40 mineral oil in the BRP supercharged wet clutch application.
    Last edited by Jeepster; 08-04-2008 at 06:34 PM.

  10. #10
    Will do I already ordered the oil extractor.
    Last edited by super_gtx; 08-04-2008 at 07:36 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. What is your opinion on using this oil in an XL760?
    By shawnmd in forum Yamaha Open Discussion
    Replies: 1
    Last Post: 08-30-2010, 09:13 AM
  2. Can i use this oil??? (90 SuperJet)
    By johnson8537 in forum Yamaha Open Discussion
    Replies: 2
    Last Post: 05-30-2009, 12:39 AM
  3. Whats wrong with using this oil?
    By 240witSR in forum 2-Stroke Performance
    Replies: 18
    Last Post: 05-29-2008, 03:02 PM
  4. I do I have to use Bombadier oil?
    By jusmoov in forum 2-Stroke Performance
    Replies: 51
    Last Post: 03-14-2008, 06:09 PM
  5. Should I use this prop
    By Flying Scotsman in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 06-05-2007, 08:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •