Results 1 to 6 of 6
  1. #1
    davidw's Avatar
    Join Date
    Apr 2008
    Location
    Near Philly / LBI
    Posts
    288

    Need Help 07 FX HO....

    Recenlty got R & D ride plate. Speedo wasn't working after insall. Shop shimmed it so speedo would work but now it's only reading 46 /47 mph max. ( anolog and digital ) RPM's are reading approx 9500 ( anolog )
    Feels lile it's running fine but the speedo thing has me concerned.
    ( 100 hrs to date and all Yami maintainence done as required ) . The shop doing the work is a Kawi joint that works on all ski's but I know that Kawi's is their specialty. ( It's at the Kawi place because that's where I rent a sport port for the summer ) Any clue what could be up???
    ( also got solas impellor and R & D intake grate when ride plate was put on... )


  2. #2
    davidw's Avatar
    Join Date
    Apr 2008
    Location
    Near Philly / LBI
    Posts
    288
    Anyone ???

  3. #3
    SHO What????? jpack's Avatar
    Join Date
    Jan 2007
    Posts
    720
    +1
    1
    Quote Originally Posted by davidw View Post
    Anyone ???
    use a GpS to address your concerns. Stock speedo's are not very reliable.


    Jim

  4. #4
    Aftermarket plate + stock dreamo=even more erratic readout. Throw the stock away and use a GPS.

  5. #5
    fx160's Avatar
    Join Date
    Nov 2005
    Location
    gold coast australia
    Posts
    2,409
    +1
    193
    Quote Originally Posted by VOODOO View Post
    Aftermarket plate + stock dreamo=even more erratic readout. Throw the stock away and use a GPS.

    +1

  6. #6
    BarBayBULL BAR BAY H.O.'s Avatar
    Join Date
    Jun 2007
    Location
    Barnegat Bay
    Posts
    1,341
    My stock speedo was actually pretty close in decent water.
    I got the Riva grates and same problem as Dave with his RD grate.
    It would be nice to get it back to stock accuracy even if its not dead on.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need 07 fx ho MR-1 service manual
    By mikeFZR in forum Yamaha PWC Performance (4-stroke)
    Replies: 1
    Last Post: 10-18-2017, 02:11 PM
  2. HELP.. 07 FX ho broke
    By john07ex in forum Yamaha PWC Performance (4-stroke)
    Replies: 9
    Last Post: 08-10-2012, 11:13 AM
  3. Need help finding FX HO
    By skigirl1 in forum Yamaha Open Discussion
    Replies: 5
    Last Post: 04-14-2010, 11:49 AM
  4. I need help with FX HO Mods
    By Speiser in forum Yamaha PWC Performance (4-stroke)
    Replies: 41
    Last Post: 07-29-2009, 10:57 PM
  5. HELP!!! Needed with '06 FX HO
    By sy34010 in forum Yamaha PWC Performance (4-stroke)
    Replies: 2
    Last Post: 08-20-2008, 08:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •