Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1

    Trim not working

    Could anyone help me i recently bought a polaris slxh and the trim isnt woring, and the annoying thing is its set in the upwards possition which is making the craft plane alot, the motor works and the switch is working what is it in between that helps control the trim, Its like there is no power getting to it, Could someone please help asap and i have spent 2 nights in the rain now scratching my head and playing with things

    Thanks

    Brad


  2. #2
    jtswatertoy's Avatar
    Join Date
    Jun 2008
    Location
    Douglasville, Ga
    Posts
    202
    +1
    5
    Have you checked the fuse that powers your trim ????

  3. #3
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Brad..You could have a bad switch or a broken or bad connection..Take the switch cover apart and get a test light..See if your getting power to the switch..If you are then there is a break in the wiring somewhere between the switch and the trim motor..If you not getting power to the switch then see if you have a break or bad connection between the switch and power source..If that is all good then chances are you have a bad switch..I dont know if the polarisis have a fuse block but you could also check for a blown fuse...

    Oh ya....Maybe have a Moderator move this to the polaris section too..Your chances of getting a acurate answer will be much better than in the sea-doo section...Good luck!!!

  4. #4
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    moved to Polaris section .

  5. #5
    which fuse is it i can see to glass 1,s

  6. #6
    can the switch be stripped down without damaging it?

  7. #7
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Before you do anything press the bilge button. While holding the bilge button down, try the trim and see if it works.
    Does the bilge motor work with the bilge button pressed??
    Last edited by ph2ocraft; 08-04-2008 at 01:20 PM.

  8. #8
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    .
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	1992-1998FactoryManual_0001.jpg 
Views:	53 
Size:	536.3 KB 
ID:	86835  

  9. #9
    what is the small black box with 3 wires coming from it inside the fuse box?? Could this have anything to do with the control of the trim??

  10. #10
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Yes, that's what you want to verify.
    If the trim and bilge work when pressing the biloge button it let's us know if your components are attached and at least working.
    If it does nothing we'll have you start the craft and verify you have 12 volts exiting the orange wire.
    If it doesn't, you need to verify it has power going into the unit (red/purple).
    Start with that and let us know what you find.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Speedo/Trim not working anymore...
    By aha in forum 4-Tec Performance
    Replies: 6
    Last Post: 05-11-2008, 03:06 PM
  2. mfd and trim not working
    By allpolaris in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 03-27-2007, 08:28 PM
  3. Trim not working?
    By YJSONLY in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 02-10-2007, 02:07 PM
  4. 2005 RXP Trim not working?
    By idizzy in forum 4-Tec Performance
    Replies: 10
    Last Post: 06-27-2006, 05:41 PM
  5. Trim not working after winter
    By SpeedStang95 in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 05-02-2006, 08:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •