Results 1 to 8 of 8
  1. #1

    '96 Zxi 900 Slow

    I've got a '96 ZXI 900 that has a top speed of something like 45. Compression is good in all three. Any ideas?


  2. #2
    axgrider73's Avatar
    Join Date
    Feb 2007
    Location
    Southeast Ohio
    Posts
    2,059
    Can you give us more details??? What are your compression numbers?

    Are there any handling mods on the ski (ride plate, sponsons, etc.)

    Is 45 mph a GPS speed rating or off of the speedo?

    Where do you have the trim set?
    The more info you can give us the better we can help.

  3. #3
    Sounds like he left the parking brake on....LOL Just kiddin. What kind of rpm's you turning?

  4. #4
    All 3 are sitting just shy of 150. No mods what so ever on this ski. It si 45 MPH on the Speedo. I've tried the trim in neutral and slightly down, and slightly up and don't get a signifigant difference anywhere.

    I'll have to look to see what the RPM's were at, it's been a few weeks since I ran it last.

  5. #5
    axgrider73's Avatar
    Join Date
    Feb 2007
    Location
    Southeast Ohio
    Posts
    2,059
    trimming up should result in increased speed over neutral or down. However, this will normaly also result in porposing. It's a fine line.

    What do the plugs look like?

  6. #6
    axgrider73's Avatar
    Join Date
    Feb 2007
    Location
    Southeast Ohio
    Posts
    2,059
    I was reading your other post; does the trim work properly?

  7. #7
    Trim was working when this problem arose. I haven't checked them yet. Just got a box of new plugs, so will check those tonight.

  8. #8
    got da fever! dzldogg's Avatar
    Join Date
    Apr 2008
    Location
    new port wrinkles,fl
    Posts
    43
    Quote Originally Posted by bcgriff View Post
    All 3 are sitting just shy of 150. No mods what so ever on this ski. It si 45 MPH on the Speedo. I've tried the trim in neutral and slightly down, and slightly up and don't get a signifigant difference anywhere.

    I'll have to look to see what the RPM's were at, it's been a few weeks since I ran it last.
    150??!!??!!!!!! Holy crap,u sure? That thing should run like a beast..I think max is like 135 on a triple...mine suck at like 106 each.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 zxi 900 carb specs
    By twostroke in forum Kawasaki Open Discussion
    Replies: 1
    Last Post: 08-25-2011, 12:05 AM
  2. What is the pop off pressure of a 96 ZXI 900
    By chvscks319 in forum Kawasaki Open Discussion
    Replies: 0
    Last Post: 10-18-2010, 01:22 PM
  3. 96 ZXI 900 No Display on Any Gauges
    By bcgriff in forum Kawasaki Open Discussion
    Replies: 1
    Last Post: 05-20-2009, 03:38 PM
  4. '96 ZXI 900 Trim Box Removal?
    By bcgriff in forum Kawasaki Open Discussion
    Replies: 6
    Last Post: 08-05-2008, 11:23 PM
  5. 96 zxi 900
    By cardudenc in forum Kawasaki PWC Performance (2-stroke)
    Replies: 0
    Last Post: 07-04-2007, 10:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •