Results 1 to 9 of 9
  1. #1

    Join Date
    Aug 2008
    Location
    RALEIGH NC
    Posts
    5

    Post 99 Xpl Damaged Pistons

    I Had A Good Running Seadoo Til It Tried To Eat A Piston, Only Thing I Could Find Was One Of The Carbs Filters Was Partially Clogged And It Wasnt The Cylinder That Messed Up, Could See Some Detonation On Top Of Piston But Never Heard It, Also Once I Tore It Down It Has Sbt Pistons In Her , I Know They Are Junk, Question Is I Need Pistons And A Head Cylinders Are Already At 1 Mil Over Would It Be Better To Go With Another Engine Or Fix This One
    Last edited by pyroguy1974; 08-07-2008 at 07:54 PM.


  2. #2

    Join Date
    Aug 2008
    Location
    RALEIGH NC
    Posts
    5
    someone please give me some ideas on this thing

  3. #3
    wedoseadoo's Avatar
    Join Date
    Sep 2006
    Location
    lake martin, al
    Posts
    220
    Pop a new set of liners in it and go back to std bore size or go with a set of 1.400 o/s wisecos you will still be able to bore up to 2.00 but you will have to cut the raves back some more for clearance.You will have to either cut the raves or replace them either way you go.

  4. #4
    Master of the Dooniverse
    Join Date
    May 2006
    Location
    Schenectady, Ny
    Posts
    597
    wrong forum, but just go with the 1.4 oversize from Wiseco. on stock it will be fine with the stock head.

    you will need to grind back the raves a bit, but i'd have to assume that was done already since it was at 1mm over.

  5. #5

    Join Date
    Aug 2008
    Location
    RALEIGH NC
    Posts
    5
    not certain if raves have been cut that may be what got the piston i need to look closer i guess. all my shit is hand grenading right now i just tore something up in my warrior motorcycle transmission . its great to be me . lol thank god im a mechanic

  6. #6
    MILLER PHASE 3 1050's Avatar
    Join Date
    Sep 2006
    Location
    909\951
    Posts
    708
    +1
    3
    or if you want to go back to std bore just buy a top end from somebody for like 300-350 and ull be ready to go once again ...check the fuel on and off switch ...id just bypass that and just used the reserve line ...good luck man

  7. #7

    Join Date
    Aug 2008
    Location
    RALEIGH NC
    Posts
    5
    i was wondering ive heard alot about the 1050 kits but cant find any one who makes stuff for a 99

  8. #8
    Still crazy after all these beers Mac Daddy Racing's Avatar
    Join Date
    Jul 2007
    Location
    St. Paul MN
    Posts
    290
    We always added a couple of gaskets under the RAVE valves to make up for the overbores. Guy in MN did/does the 927 kit on the 800's. Need to run 110 but is sounds and smells great!!

  9. #9
    Master of the Dooniverse
    Join Date
    May 2006
    Location
    Schenectady, Ny
    Posts
    597
    Quote Originally Posted by Mac Daddy Racing View Post
    Need to run 110 but is sounds and smells great!!
    LMAO.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Installing Wear Ring in 99 XPL
    By cws in forum 2-Stroke Performance
    Replies: 7
    Last Post: 07-29-2007, 08:10 PM
  2. 99 XPL lanyard problem
    By Duke in forum 2-Stroke Performance
    Replies: 9
    Last Post: 07-18-2007, 04:18 PM
  3. 98 xpl wear ring vs. 99+ xpl wear ring
    By JayZ in forum 2-Stroke Performance
    Replies: 9
    Last Post: 07-03-2007, 09:24 AM
  4. Removing Seat Strap - 99 XPL
    By hemicuda in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 03-12-2007, 03:27 AM
  5. Anyone damage pistons?
    By engineermike in forum 4-Tec Performance
    Replies: 5
    Last Post: 03-09-2007, 04:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •