Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 39
  1. #1

    Join Date
    May 2007
    Location
    Melbourne, FL
    Posts
    154

    Who contacted Kawi direct about GIO

    I'm just curious, for those with GIO (Gas in Oil) who contacted Kawi direct by phone, mail or email?

    Everytime I called they claimed no one else was contacting them about it. I wrote and called, anyone else contact them direct in addition to bringing it to the dealers attention?

    I'm just curious as to how many of us contacted them directly. I know they don't care, but how many of us were told they don't care directly by Kawasaki as oppsosed to the dealer.


  2. #2
    I'm just curious as to how many of us contacted them directly. I know they don't care, but how many of us were told they don't care directly by Kawasaki as oppsosed to the dealer.


    I find it highly unlikely that you were told by Kawasaki that they dont care.Of coarse Ive been wrong before.

    Also try and use the search button. Do some searching and your question could be answered.

  3. #3

    Join Date
    May 2007
    Location
    Melbourne, FL
    Posts
    154
    I'm not looking to argue Skip, but can't find one thread where they've done anything for anybody.

    I appreciate your loyalty to Kawasaki, and wish I could just trade up and out to an 08 like yourself.

    It is interesting though, how they have a design change and hang the 07 guys out to dry ( I know, I know, put an OCMS on it) We could debate all day long as it already has been debated. I'm just curious as to how many have contacted them vs the fact they claim no one has. To me it's worth justifying. A $11K investment might not be much to you, but I'm tired of the investment in oil changes, let alone my time doing it for something bought for recreation not a service headache. Kawi told me directly that they now know the manual is wrong to expect 50 hour oil changes, well if that is their final opinion, they should send out an addenum to the owners manual. Why won't they do that, admittance of a problem, of course. They also came up with the excuse that it was a race machine and people go too slow and cause the problem. Excuse me, do you know anybody who buys such a ski and "putters around" on it. The response letter also said cold weather causes the problem. Uh, maybe they should have looked at the address they just mailed the letter to me at, Florida.

    All I'm asking is who else has cared enough about their investment to contact them directly. They tell me none. I don't believe that to be the case, and curious as to who else has made contact to them direct.

    I don't hate my ski, but certainly does not live up to what I paid for, and am stuck with something that has a black GIO cloud over it

  4. #4
    50 hour oil changes??

    If there is even a smal GIO issue, no more than 10 hours at best.

    If you ride hard, I suggest oil change at 5 hours.

    Personally, I have just accepted the oil change issue and look for deals on good, yet inexpensive oil..... I love the hull for the rough!

  5. #5
    gregt909's Avatar
    Join Date
    Jun 2008
    Location
    Montgomery Texas
    Posts
    64
    Quote Originally Posted by Socaloffshore View Post
    50 hour oil changes??

    If there is even a smal GIO issue, no more than 10 hours at best.

    If you ride hard, I suggest oil change at 5 hours.

    Personally, I have just accepted the oil change issue and look for deals on good, yet inexpensive oil..... I love the hull for the rough!
    50 hours is what kawi's manual says. I agree, I would never go 50 hours between oil changes but if Kawi puts it in print I would say it's reasonable to expect to go 50 hours between oil changes.

  6. #6
    TangorZX's Avatar
    Join Date
    May 2008
    Location
    Spring, TX
    Posts
    26
    Efizjb,
    Not to derail the thread but I noticed that you have a ticker Tacoma listed in your sig. I used to have an '06 and they addressed the ticking with a recall. They put new exhaust manifolds on it. There is an offical Toyota TBS on it.

    EG021-06 APR 06 Exhaust System - Ticking Noise Between 2,000-2,500 RPM

    http://www.divshare.com/download/4099372-c01

    http://www.toyotanation.com/forum/sh...d.php?t=186199

  7. #7
    Gen3Benz's Avatar
    Join Date
    Jun 2008
    Location
    Phoenix AZ
    Posts
    158
    Quote Originally Posted by efizjb
    I'm just curious, for those with GIO (Gas in Oil) who contacted Kawi direct by phone, mail or email.
    Do you have thier phone number or email address, ill contact them


    Quote Originally Posted by TangorZX
    I used to have an '06 and they addressed the ticking with a recall. They put new exhaust manifolds on it.
    I have an '07 taco and it ticks.
    I think its the lack of hydraulic valve lash adjusters.
    I dont mind if it sounds like a sewing maching, its the best midsize truck made.

  8. #8

    Join Date
    May 2007
    Location
    Melbourne, FL
    Posts
    154
    Had the Tacoma TSB done, no change.

    As far as calling Kawi, the # is on their site, but I think you'll get the same response, hence why I'm asking who's actully made contact other than thru the dealer. Dealer was willing to assist, Kawi on other hand not so much.

    Change oil every 5 hours, makes sense to protect investment, makes no logical sense why one should have to be subject to it.

  9. #9
    The beauty of this country is the freedom to sell it and buy something else.

    Maybe you should sell your unit and buy something else. I would suggest you stay away from forced induced machine as they are more prone to having issues.

  10. #10
    kman's Avatar
    Join Date
    Aug 2007
    Location
    Labrador
    Posts
    193
    To answer your original question rather than derailing this thread any more, I mailed Kawi Canada telling them about the GIO problem and sent them an oil sample test result after only 3-4 hours that was full of gas. I asked them what to do about the problem as I'm not near a Kawi dealer. I received no response. That was about 5-6 months ago.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. To those who are worried about fuel consumption with the Kawi 250/260/300/310x
    By SuperCharged67 in forum Kawasaki Open Discussion
    Replies: 0
    Last Post: 07-09-2014, 06:09 PM
  2. ok who really knows alot about the 951 white motor ???
    By big john in forum 2-Stroke Performance
    Replies: 12
    Last Post: 10-18-2010, 11:54 AM
  3. Re: Contacting me (Shibby) about dealer related questions
    By Shibby1485 in forum Sea Doo Open Discussion
    Replies: 22
    Last Post: 03-07-2009, 09:24 AM
  4. Did kawi fix the GIO prob for 08?
    By mooneyb91084 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 2
    Last Post: 04-08-2008, 07:45 PM
  5. Kawi and the GIO...again
    By benjahw in forum Kawasaki PWC Performance (4-stroke)
    Replies: 29
    Last Post: 03-13-2008, 08:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •